Render window does not remember size

It has been that way all the time I guess.
Every time when I want to render a project, the appearing window is to small to see all the available options.
I mostly use H.265 and prefer 80% quality.
So in order to set that, I need to enlarge the window.
Somehow by design I guess but it would be nice to have that window remember its size.
Or is there a setting in kdenlive to get what I am looking for?