Rescale while rendering + Transform effect = cropped video of top left corner

This problem came up out of the blue about 4-5 months ago. I use the Flatpak version of Kdenlive on the latest Linux Mint. Whenever I use the Transform effect on a video (my project profile is 2704x1520 50fps) and then render the project with Rescale enabled to 1080x1921 instead of rescaling it seem as though the video just gets cropped to the top left corner. I tried uninstalling and reinstalling kdenlive but this bug remained.
Please help me.

Hmm, I though the dimensions need to be multiples of 2. And what do you use the Transform effect for?

These are the dimensions I used before it stopped working, and the bug happens even if I use the Transform effect only to pan and zoom.

By the way I noticed that my Linux kernel is out of date, I’ll update it today and see if that helps.

Turns out I am running the latest recommended kernel which is 5.15.0-73
I am able to work around the problem by first rendering without rescale and with all the effects in 2.7k and then rendering the output file again only the second time being with rescale and no effects.
I guess that’s how I’m going to continue doing things until hopefully this gets fixed in some future kdenlive update.

I stumbled onto a solution. After inserting a new video track to the project the problem went away and didn’t return even after I later deleted that video track.

I had a similar issue with the master effects, after I would render the project and play the file I noticed that in certain places the master effects would turn off for a few seconds. Eventually I found that by deleting all the master effects and adding them back in the problem went away.

Hope someone finds this information useful.

1 Like

Hi, I think I have the same issue. I’ve used the transform effect and the video looks OK in the preview, but after rendering the video is zoomed in to part of the screen the whole length of the video.
I’m on Windows 10 and using kdenlive 23.04.0-1.
I tried adding a video track but it doesn’t change anything.
If I disable the transform effect, the video is rendered correctly.
I believe there is something else going on here…