[Resolved] Plasma 6 Lock screen repeatedly shakes and says "unlocking failed"

I’ve been using KDE 5 on Wayland (EndeavourOS, AMD graphics) with no issue, but the following happens with KDE 6 (I’ve restarted multiple times after the update):

I press ‘lock’ from the start menu (or the computer locks itself after inactivity). Then, the wallpaper and time/date shows up as normal. However, when I jiggle my mouse / try to type in my password, my username and icon appears as normal, but underneath it it says “Unlocking failed” and shakes the whole “thing”, repeatedly. All of the buttons and the field to enter my password are disabled / grayed out, and clicking on them did not do anything.

I believe this isn’t a hardware issue, since it doesn’t seem to affect normal usage at all, but I have no idea how to troubleshoot this at all. Googling did not give me anything even remotely close to what I’m experiencing.

How did you manage to eventually unlock the screen?

I switched to another TTY with Ctrl-Alt-F3, logged in, then typed loginctl unlock-session 2.

Maybe what you see is the result of you being locked out (10 minute lockout) by entering a wrong password (n times) in some other place, or check if you have all the pam packages or if there is any misconfiguration Security - ArchWiki

I tried this but couldn’t get anything to fix it so I took the… semi-nuclear option of reinstalling every single package.

That fixed it, but I still don’t know what the cause is. Oh well, it doesn’t really matter.