[Rhythmbox] iPod not recognized (certainly KDE related)

Hello everyone,

I recently tried KDE and have an issue with Rhythmbox and the iPod Video 5th gen. The iPod is properly recognized in Rhyhtmbox on other distros and other DEs, like XFCE and so forth.
In KDE the iPod is not recognized within Rhythmbox.
After manually mounting it with Dolphin it still can not be recognized.
I just tried in a standard MX Linux XFCE Desktop and it works without problems.
This seems to be clearly related to how KDE is handling iPods and similar devices.
Can anybody shine some light on this issue? Am I the only Rhythmbox user on KDE user with an iPod?
It is keeping me from using KDE, which is otherwise a very mature DE.
The iPod itself of course is recognized by the KDE system and can be mounted and I have read/write permissions, all good on the OS side.

starting rhythmbox with the debug flag I get one interesting output:

(17:39:05) <rhythmbox> [uevent_cb] ../shell/rb-removable-media-manager.c:525: add event for /sys/devices/pci0000:00/0000:00:14.0/usb2/2-1 (bd89)
(17:39:05) <rhythmbox> [create_source_device_cb] ../plugins/mtpdevice/rb-mtp-plugin.c:204: matching device 5ac:1209 against libmtp device list
(17:39:05) <rhythmbox> [create_source_device_cb] ../plugins/mtpdevice/rb-mtp-plugin.c:232: device didn't match anything
(17:39:05) <rhythmbox> [uevent_cb] ../shell/rb-removable-media-manager.c:525: add event for /sys/devices/pci0000:00/0000:00:14.0/usb2/2-1/2-1:1.0 (0)
(17:39:05) <rhythmbox> [create_source_device_cb] ../plugins/mtpdevice/rb-mtp-plugin.c:200: couldn't get vendor or model ID for device (0:0)
(17:39:05) <rhythmbox> [uevent_cb] ../shell/rb-removable-media-manager.c:525: bind event for /sys/devices/pci0000:00/0000:00:14.0/usb2/2-1/2-1:1.0 (0)
(17:39:05) <rhythmbox> [uevent_cb] ../shell/rb-removable-media-manager.c:525: bind event for /sys/devices/pci0000:00/0000:00:14.0/usb2/2-1 (bd89)

The USB identifier for the iPod is:

Bus 002 Device 010: ID 05ac:1209 Apple, Inc. iPod Video

Please let me know if I can provide any other debugging information or logs.

1 Like

So you can see the iPod in Dolphin, but not in Rhythmbox? It doesn’t appear in Rhythmbox at all? Or it does appear, but its contents aren’t accessible?

How exactly are yo making it appear in Dolphin? Just clicking on it in the sidebar?

And yes, I suspect you may in fact by the only person using Rhythmbox with an iPod on Plasma. :slight_smile:

Hi @ngraham Nate,

thank you for answering.

I can see it in Dolphin, then I click on it to mount it.
Afterwards I start Rhythmbox.
In Rhythmbox it does not appear at all. It should appear in the sidebar (just checked with XFCE) under the category “devices”. The category itself also is not shown. I think it shows up only when you have one or more devices active.

(off topic: I may be the only one, at least the only one taking the time to resort to the forum. iPods are still today one of the best audiophile devices out there if you are not in to the whole streaming ecosphere and the disadvantages that come with it. The iPods 5th gen and 5.5gen are still rocking my world. I have multiple modded with 500GB SSD storage, better capacitors and bigger batteries. I wouldn’t care to replace them with any of the “new” stuff.)

Oh, and with gtkpod it does work on KDE/Plasma.

What path does it get mounted to? Click the iPod in Dolphin, hit Ctrl+L, then Ctrl+A, then Ctrl+C, then paste the copied text here.

While user is my username and TLC is the iPods Name/Label.

Ok, that’s a standard location. So I’m surprised that Rhythmbox can’t see it. It’s possible that Rhythmbox has some kind of special iPod/Apple mobile device support and that’s not working, but that it can see standard disks mounted to standard locations. So maybe try looking at that.

If that doesn’t help, I think you’ll be better off asking in a GNOME forum because this appears to be an issue with how Rhythmbox finds external disks.

OK, I’ll try some place else.

Something that stands out to me is that gtkpod uses lipgpod, while rhythmbox may use either libgpod or libmtp. See log in first post. I am not sure if libmtp is the right choice for iPods, but do not know really.

I recently was in a similar situation as them, I didn’t dive very far into it at the time but it pretty much boiled down to Rhythmbox requiring GVFS/Gnome Virtual File System for iPhone/iPod detection. I don’t think it supports the KDE equivalent of GVFS (kio-fuse I think?), at least in regard to detecting iPod/iPhone.

@4L3X I wasn’t able to get it to work either, but hopefully this helps point in the right direction to find the solution!

1 Like

Alright, so an install of gvfs-backend and a reboot did the job. iPod is back online. :partying_face:

1 Like

Glad to hear it. If installing the app didn’t pull that in as a dependency, IMO that’s a packaging error or a build system error on the part of the app itself. Optional dependencies are evil! :slight_smile:

1 Like

Smells like python :rofl:

Here is the apt show result:

$ apt show rhythmbox -a
Package: rhythmbox
Version: 3.4.6-2+b1
Priority: optional
Section: gnome
Source: rhythmbox (3.4.6-2)
Maintainer: Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>
Installed-Size: 646 kB
Depends: libc6 (>= 2.34), libglib2.0-0 (>= 2.68.0), libgstreamer-plugins-base1.0-0 (>= 1.4.0), libgstreamer1.0-0 (>= 1.4.0), libgtk-3-0 (>= 3.20.0), libpeas-1.0-0 (>= 1.0.0), librhythmbox-core10 (= 3.4.6-2+b1), libx11-6, rhythmbox-data (>= 3.4.6-2), dbus, gstreamer1.0-plugins-base (>= 1.4.0), gstreamer1.0-plugins-good (>= 1.4.0), gstreamer1.0-x, media-player-info
Recommends: yelp, avahi-daemon, notification-daemon, gstreamer1.0-plugins-ugly, gvfs-backends, rhythmbox-plugins
Suggests: gstreamer1.0-plugins-bad, gnome-codec-install, gnome-control-center, rhythmbox-plugin-cdrecorder

I’m currently reporting the bug to the debian package maintainer(s).

I was trying to report the bug to debian, but the reportbug cmd line client hangs for many hours when quering the BTS. I can’t send the report. Sorry people. But I think we have very good SEO for this bug now, anyone should find one of the threads I opened here or with GNOME.