Screen Resolution [ Need Above 1024 x 768 ]

Hello Team,

I am facing an issue with the screen resolution.
The resolution I get is 1024 x 768. [ Maximum ]

I want a higher resolution. I’m on BlendOS using KDE.

Things I tried are,

  1. Tried with " screenrez " app to increase the resolution.
    But no luck.

Here is the link for reference

ScreenRez - KDE Store

Request the team to assist with fixing the resolution issue.

Thanking you,

Please go to System Settings > About this System and copy the info to the clipboard. Come back and post it here. That will give everyone more info to go on. :slightly_smiling_face:

Please find the information below

Operating System: blendOS
KDE Plasma Version: 5.27.6
KDE Frameworks Version: 5.107.0
Qt Version: 5.15.10
Kernel Version: 6.3.9-zen1-1-zen (64-bit)
Graphics Platform: Wayland
Processors: 4 × Intel® Core™2 Quad CPU Q8400 @ 2.66GHz
Memory: 3.8 GiB of RAM
Graphics Processor: Mesa Intel® G41

1 Like

Run kscreen-doctor -o in a Terminal and post the output here.

Do you know if your monitor supports more than 1024 x 768 ?

Please find the information for the executed command

[nagarjun@blend screenrez]$ kscreen-doctor -o
Output: 1 VGA-1 enabled connected priority 1 VGA Modes: 0:1024x768@60*! 1:800x600@
60 2:800x600@56 3:848x480@60 4:640x480@60 Geometry: 0,0 1024x768 Scale: 1 Rotation
: 1 Overscan: 0 Vrr: incapable RgbRange: unknown
malloc_consolidate(): invalid chunk size
Aborted (core dumped)

Would like to share that on Windows 10 pro, I get bigger resolutions. I’m hoping the same on Linux.

If there is any other information you need, please let me know.

Please find the snapshots of the Image :

  1. Terminal

Team, please assist me with fixing the resolution issue.

As I was working on this, I came across the " ScreenRez " Widget in Add Widgets. [ Right click Menu ]

I’m attaching the image for your reference.

Although, the ScreenRez appears on the widget list and upon adding, it does
nothing. There is white square. Yes its re-sizable, but it becomes blank.

I moved the white square piece on to the taskbar.
It doesn’t show the resolutions

When I click on the ScreenRez icon, it shows a white rectangle.
It doesn’t show a single value. I have drawn a red circle on it.

Please find the attachment for reference.

Please assist, to get the right resolution.

As I keep working on the screen resolution issue, I probed the hardware.
I come to know that its i915

Please find the link below for reference

[nagarjun@blend foxit_]$ lsmod | grep i915

i915 4149248 75
drm_buddy 20480 1 i915
i2c_algo_bit 24576 1 i915
ttm 106496 1 i915
drm_display_helper 221184 1 i915
video 73728 1 i915
cec 98304 2 drm_display_helper,i915
intel_gtt 32768 2 intel_agp,i915

[nagarjun@blend foxit_]$

Could the team help me understand that,

  1. I need to update the drivers for i915
  2. as to get a bigger resolution

Please suggest.

This is possibly an issue with BlendOS.

Do other DEs (desktop environments, such as Gnome) on BlendOS work fine?

Also has this resolution worked for you before on BlendOS, and if so, have you reinstalled BlendOS since it last worked?

Can you log in to a X11 session and run xrandr command and see if there is a resolution above 1024 x 768?

If there is not, it will probably difficult, but not impossible.

Ref :

[nagarjun@blend ~]$ lspci -k | grep -EA3 ‘VGA|3D|Display’
00:02.0 VGA compatible controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)
Subsystem: Intel Corporation 4 Series Chipset Integrated Graphics Controller
Kernel driver in use: i915
Kernel modules: i915
[nagarjun@blend ~]$

With reference to the above information, I understand that the drivers of the
graphic card i915 have to be updated.

Please help me, with the next part.

Here is the information for the command " xrandr "

[nagarjun@blend ~]$ xrandr.Ubuntu_23_04
Screen 0: minimum 320 x 200, current 1024 x 768, maximum 8192 x 8192
VGA-1 connected primary 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
1024x768 60.00*
800x600 60.32 56.25
848x480 60.00
640x480 59.94
HDMI-1 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)
[nagarjun@blend ~]$

I understand that the drivers of the
graphic card i915 have to be updated.

This will be something you will need to ask BlendOS (or users of it) about, I have no experience with that distro. Although, as far as I know, its normal for the i915 kernel driver to be used for intel integrated graphics.

Hello Team,

I’d like to share this information with you as it would help an other person with the screen resolution issue.

  1. I switched to Fedora 38
  2. I got the same resolution earlier i.e 1024x768

then, I did the following :

Disabled the Wayland at

  1. /etc/gdm/custom.conf

Need to remove the #

Uncomment the line below to force the login screen to use Xorg


Next step

I hope this information will be of help to you.