Screensharing not working for any application in KDE 6, Wayland

For the last few weeks, screen sharing for any application (Google Meet on Chrome or Firefox, Slack) no longer works at all. When the screen-sharing dialogue pops up (which has been popping up twice since the KDE 6 upgrade/switch to Wayland, as noted in this issue from another user), the “Share” button is grayed out, no matter what option I select - see screenshot below.

Is there anything that could be holding up permission to screenshare that I might be able to address? This is seriously impacting my work, as this is my main work machine.

Love KDE, and have been a regular donator for years - thank you all for all the good work!

Three questions for you:

Did you click on the checkboxes, rather than the backgrounds of the cards?

If you click on the backgrounds of the cards, does the “Share” button become active?

What’s the easiest way to reproduce this?

Hey there, figured I’d pipe up I’m having this issue as well.

Indeed, I was clicking on the checkboxes directly. I would have to click several checkboxes several times to get the share button to activate, and even once doing that, the resulting stream would be non-functional.

I tried this on the latest versions of Fedora and Nobara and had it happen on both.

Now having seen this thread, I tried clicking the backgrounds of the cards, and I can get streaming to happen now. (Once of course doing the change window shuffle electron bug…)

If wanted I can grab video of the behavior, or offer up any other info on versions/software you think might be relevant.

Aha, then this is 481461 – Clicking checkbox to select content to share does not work.

I’ll try to fix it as soon as I can reproduce it. Unfortunately our test app does not exhibit the problem. Can you tell me the easiest way to reproduce it?

1 Like

Btw, the checkboxes are gone in Plasma 6.1, so there’s only one correct way of selecting the video source now.

1 Like

Thank you all for the insight, and sorry for the slow reply (weekend)! This indeed fixed it for me as well - just clicking on the boxes instead of the checkboxes.

And re: the easiest way to reproduce it - I’m really not sure, as I can’t get it to not happen, and I’m not aware that I’m doing anything special to cause it. I simply start a Google Meet (or whatever) session, and click the Screen Share icon.