Screenshot issue when using external monitor

Hi Team,
Hope the community is doing great!

Issue: I am facing an issue when I try to connect an external monitor and take a screenshot using tools like flameshot or spectacle.

Without the external monitor, I am able to use the laptop display to take screenshots (both full and selected region). The moment I connect external monitor and try to take a screenshot, the entire screen on both the monitor and laptop will shift a little.

The issue is explained here by another user. I am exactly facing the same issue.

My configurations:

Laptop: Thinkpad E14 (1920x1080 @ 60Hz)
Monitor: Samsung 21" (1600x900 @ 60Hz)
OS: KDE Neon
Kernel Ver: 6.5.0-21
Plasma Ver: 5.27.10
Platform: X11

Could this be a possible bug? or am I doing something wrong?
Also to note, I am also using Global Scaling 125%

And using xrandr to set monitor and laptop screen with 2x2, 1.5x1.5 is not working. The screenshot issue still persists.

Kindly help me resolve this.

(Edit - my apologies, I misread your post. Did you define your screen sizes and positions with XrandR? For example mine looks like this:

xrandr --output DVI-D-0 --mode 1280x1024 --pos 0x0 --rotate left
xrandr --output HDMI-0 --primary --mode 1920x1080 --pos 1024x0 --rotate normal
xrandr --output DVI-I-1-1 --mode 1280x1024 --pos 2944x0 --rotate left
xrandr --output DVI-D-1-0 --mode 1680x1050 --pos 3968x0 --rotate left
xrandr --output HDMI-1-0 --mode 1920x1080 --pos 5018x0 --rotate normal

(The link you posted did not mention scaling, so I suspect the issue is SDDM.)

Sounds to me like you are doing something wrong. I use 5 displays, 2 in landscape, three in portrait, and with a mix of resolutions from 1280x1024, 1680x1050, and 1920x1080. Spectacle defaults to entire active desktop, but you can reconfigure it. What I did was change the keyboard shortcuts to take a normal “active screen” (whichever screen the mouse is on) with {print screen}", then {shift}{print screen} for the “active window”, and {ctrl}{print screen} for the “entire desktop”. You can configure this within spectacle.

(this one has the mouse over the sceen using just print screen key)

Hi @shadow
Thanks for correcting your post.

I am just using default KDE Neon settings on my laptop. My laptop is running 1920x1080 @ 60Hz. And the external monitor I am using is 1600x900 @ 60Hz.
Here is how it looks in settings,

I tried using xrandr scale 1.2x1.2 and also few other ones, but my resolution is getting messed up.
However, I am using a global scale at 125% in display configuration. I get to see that there is no way to set per screen-based scaling. (guess that is just a wayland feature and missing in X11).

My left monitor connected over HDMI-2 just feels a little zoomed in. And if I try to reduce the size using scale 1.2x1.2, I get black borders on right and bottom or part of my laptop screen comes on my monitor and things look broken like so,

And if I keept it at 1x1, then everything looks fine (when i try to take all desktops screenshot)

But the moment I try to use rectangle/region-based screenshot, things break again. Like this

I think this is a bug, I have seen an option to scale each display separately before in KDE, but that was long time back. Don’t know why it’s not showing up in settings panel now.

I am yet to try it with a 1920x1080p monitor and see if that works.
Let me know if I need to provide any other details or try anything else.



I updated to plasma 6 yesterday and tried using the default global scaling to 100%. Today I tried connecting with the same external 720p monitor and voila!. Screenshot is not breaking screen anymore.

A part of the issue is resolved, don’t know if the issue was due to scaling or something else (plasma related). After the update, the rectangle/region based screenshots are working as expected at global scale of 125%.

However, the tabs and applications on the monitor still feels big and I tried using xrandr scale, but that is disrupting the screen and again, part of my laptop screen is coming to the monitor side. I don’t have an option to scale the left monitor separately.

If anyone has a better idea on how I can reduce the monitor font size or scale separately without disrupting the laptop size and screen, kindly drop your thoughts.

Also to note, I am using font dpi to 120%.


The option is using Wayland.

Hi Meven,
Yes, I noticed that most of the things breaking on X11 with Plasma 6 are working fine on Wayland.

I have finally made a shift to Wayland from X11. So far, I am enjoying the gestures on my laptop.

One more thing that fixed my issue is I have kept 125% scaling on my laptop which is high dpi 1080p screen and kept 100% scaling on the 720p monitor.
Now everything seems to be normal. This feature of wayland is really great.

Even the screen tearing issue when taking screenshots is resolved with Wayland.
Though this is an upgrade, don’t know if there will be more application support to Wayland, well at least as of now.

Thanks for the suggestion.
I am considering my issue closed.

1 Like

There will support improvement (session restore…), but for things that the majority of users don’t need or can live without for now.
Wayland support has been complete enough for the majority of users for a while now and some users like yourself could have been happy with Wayland earlier, had you tried it.

The move to Qt6 allowed us to bring better Wayland support for Plasma 6. Thankfully the KWin devs and the whole KDE community have been hard at work for years to make this possible.

And it brings new features like HDR and VRR all the while being lighter weight that X11.

Even good opensource Nvidia support is around the corner NVK is now ready for prime time

That’s an a very enjoyable accomplishment to have skeptical users trying Wayland, ending up as a solution to their issue.


1 Like

Well said!
I was used to X11 from many years. Since I was using KDE Neon X11 mainstream for my gaming desktop setup, I never really went into Wayland or felt the need to.

But understanding how things are evolving and the need for another upgraded alternative, I totally understand that the change from X11 to Wayland has to be transitioned slowly.

I love the KDE community and really appreciate all the hard work and testing that goes into each and every update.

Plasma 6 is awesome! :tada:
I’m not going anywhere else, even if there are some minor issues. Most of the issues are resolved with Wayland now.
And since I am using this on my work laptop, I won’t need any gaming support.

Thanks again for the awesome developments Team KDE :innocent:.

1 Like