[SDDM] Setting the refresh rate/multi monitor setup

Hello,
I’m running plasma 5.27.6, wayland, on Arch. I’ve been wondering if it’s possible to make SSDM login screen start with 120 or 144Hz refresh rate. Reason I’m asking is because I use a high refresh rate display I get a 5s or so of black screen after login due to my monitors switching from SDDM’s 60Hz to 120Hz.
My hardware setup is Thinkpad t480s with 60Hz screen which is usually off and 2 external FHD@144Hz displays connected to a thunderbolt docking station.

I have already tried putting DisplayCommand=/usr/share/sddm/scripts/Xsetup in my /etc/sddm.conf.d/kde_settings.conf, where in the Xsetup I’ve set both my external displays to 119.93Hz but it seems to me like the SDDM just ignores that completely as it still runs at 60Hz no matter what configuration of displays is present.

Does anobody have any ideas?

How do you know sddm runs on 60 hz? Could it be it just takes a while to load everything?

You could try to use SDDM in Wayland mode and see if that changes things
(Wayland = better multiple monitor support)

If you know how to check what refresh rate SDDM runs, I can try it on the weekend.

My monitor reports the refresh rate in the OSD menu and it’s 60Hz on login screen, after I log in it blanks out for a few seconds and switches to the 120Hz (119.93Hz actually) I have set in KDE settings. If I keep my desktop at 60Hz there is none of that blanking and waiting.
That only happens on first login, afterwards, if I lock the screen manually or wake from suspend, login screen will run at whatever the desktop refresh rate is.

Oddly enough, when I wrote xrandr --output eDP-1 --off in the (internal display) Xsetup SDDM respected that and the built in screen was indeed disabled, even if it was the only connected display. So it seems like just the refresh rate settings are being ignored for some reason.

I can’t reproduce. I haven’t timed it exactly but it just takes a few seconds no matter if I use 60Hz or 144Hz. €: I am just running 1 monitor.

Note that the lock-screen is not part of SDDM (afaik).

I think that is normal and has nothing to do with SDDM or KDE. The first time you login it takes a while to load everything. Resuming from the lockscreen or sleep should always be faster.

If you still think this is a refresh rate bug, file a bug report at

This is definitely related to refresh rate, just by moving my mouse I can tell that SDDM is running at 60Hz and as I’ve said I can confirm that in the monitor’s OSD.

I’m not talking about the standard delay of about 2-3s (on my system) that it takes between logging in and seeing the dekstop. I’m talking about additional delay that is caused by KDE taking over and switching refresh rate from 60 to 120 I usually use which causes the monitor to blank out for over 5s. But I’m equally bothered by SDDM not running at above 60Hz since it just feels laggy when you’re used to higher refresh rates.

I have a related question, also with multi-monitor setup.

I use a high-DPI laptop display plus a low-DPI external one. In SDDM, I get two login screens, one per display, with low-DPI displaying nicely and high-DPI displaying tiny.

This is Fedora and Wayland.

Is there a way of having SDDM scale the high-DPI larger, but keep the low-DPI as is? This kind of per-display scaling is working perfectly in KDE session, but not in SDDM.

I’ve googled through various threads and posts but I’m quite confused about what’s applicable today. Nothing I’ve tried worked so far.

UPDATE: it magically worked after clicking “Apply Plasma Settings…” again, but I’ve already tried that before with no result o_O

The only thing is that the mouse cursor is double the size on the low-DPI display, but I can live with that.

However, what this click actually did and why only this time is a complete mystery.

Both before and after this click the state of the config files is the same:

  • /etc/sddm.conf: empty, sized 0;
  • /etc/sddm.conf.d/ with just 1 file kde_settings.conf, modification date before the click, filled in with some settings without any DPI mentioning.

Where the heck does that click apply settings, if not in these files/folders?