Second monitor not detected after login

When I log into my desktop session, the second monitor does not appear, and I have to run kscreen-doctor output.DP-2.enable to get the monitor to appear in the display and monitor settings. Then I have to change the layout so the screen aren’t stacked on top of each other. Doing this on every login is annoying, so is there something I can do to fix the issue? I’m using Wayland on an Nvidia GPU with proprietary drivers. The monitor appears fine on the login screen.

Switch to X11. Nvidia and Wayland do not always play nicely with each other. This can be done at the login screen. Did you check to see if it shows up as “enabled” in “System Settings/Display & Monitor” after login? If not, set it to enable. I noticed recent Neon updates seemed to disable one of my displays, and I needed to re-enable it there.

What Plasma version are you using?

Before you run that command, does the external monitor not appear in the Display and Monitor page at all? Or does it appear there but it’s listed as disabled?

It doesn’t appear at all. I reported this bug at 470818 – [NVIDIA] 2nd monitor not detected upon login.

Operating System: KDE neon 5.27
KDE Plasma Version: 5.27.7
KDE Frameworks Version: 5.108.0
Qt Version: 5.15.10
Kernel Version: 6.2.0-26-generic (64-bit)

Switch to X11.

Yeah that’s what Ive been doing.

click the device dropdown list…

1 Like

It’s there, just disabled. I don’t know why it disables itself every time

Either I don’t understand or you are giving us mixed signals here.

Click on this:

Is the disabled monitor listed there?

Did you try setting it to “Primary”? Once you have re-enabled the monitor, do you get the box to set the screen priorities under the box to enable it?

click the device dropdown list…

It appears there

Either I don’t understand or you are giving us mixed signals here.

I didn’t realize it’s under the dropdown.

Is the disabled monitor listed there?