Set up fcitx5 for Hanzi (chinese), now second keyboard layout in regular input disappears everytime when booting

Hi all.
Running KDE 5.27.5 on Debian Bookworm. I set up fcitx5 to be able to type Chinese. Tried IBus before that, but it was too buggy. Besides Chinese I also need Thai, which doesn’t require a different input method, just different keyboard layout. Having two keyboard layouts worked fine. Having two input methods also worked fine. Even two IM and KL together work fine. But when I reboot, my second keyboard layout disappears and I have to go back to settings every time i boot up and put the widget back.

Any help? Thanks.

So basically, Fcitx will also try to configure layout and sync it to X server / Wayland compositor.

You can either:

  1. Add multiple group / or add layout with in one group in fcitx, and switch layout with fcitx (super + space for switching group).
  2. Make fcitx to not to touch layout (Fcitx → Addon → XCB → uncheck allow override XKB setting )

Thank you for your reply.

In the meanwhile I also found this solution (cannot add link, it’s “[SOLVED] KDE/plasma resets my keyboard layout settings on every boot” on archlinux forum) making ~/.config/kxkbrc immutable.
So far it seems to work. Do you think it might cause problems later? Not planning to add / remove keyboard layouts.