Skanpage flatpak package doesn't recognize my scanner

I own a Brother scanner with USB interface. Currently I’m using the deb package of skanpage, and it has been working flawlessly for years.

Now, out of curiosity, I have installed the flatpak package, but there is no way to make the app recognize the scanner. The only “scanner” recognized is the integrated webcam of my laptop.

I understand that a flatpak package is sandboxed, hence it is expected to have some trouble with external hardware, but I thought it was possible to make it working anyway. If not, what is the use case of this flatpak package? I mean, a scanner is always an external peripheral, and it should be recognizable.

Thank you for any suggestion :+1:

in discover where the software is listed, if you select your view of the page as sourced from flathub there will be a long list of permissions you can can configure at the bottom of the page.

or you can search for and install flatseal to do the same thing.

my guess would be you need to give it access to your peripheral devices.

Hi @skyfishgoo, thank you for the suggestion.

Unfortunately though, I have already checked all the permissions, but the scanner is still not recognized. I have even turned on all the permissions (even the ones that make no sense :upside_down_face:), but still no luck.

in my (limited) experience, software that requires tight integration to hardware or system software, anything beyond user file system access really) is best served with native software.

Thank you.
So if hardware integration is, apparently, not possible, my initial question remains:

Maybe someone in this community has more information than me :blush:

1 Like