Slim log error need help

I use FreeBSD 13, I installed the X server, to start I tested xfce4 as a window manager, it works very well, I did not activate the loading of the desktop automatically but manually I did a startxfce4 . Curiosity pushes me to install Kde5, that’s what I did. I chose Slim and not Sddm as the login loader when connecting my KDE desktop. Slim does not log in, the screen stays on Slim’s crosshairs without loading the desktop. As I am afraid of making errors in the settings of Slim, I have written to you to solve my problem.
this the sample of /etc/rc.conf:

# sddm_enable="YES"

run command with powerless user :

% echo "exec /usr/local/bin/startkde5 --with-ck-launch" > ~/.xinitrc
% echo "#!/bin/sh" > ~/.xsession
% echo "exec /usr/local/bin/startkde5 --with-ck-launch" >> ~/.xsession
% chmod +x ~/.xsession

it seems that Slim is not synchronous with the users of my station.
what do you need to configure?

not using slim but sddm… so ymmv.

any reason you have gdm, kdm4 and hald enabled in rc.conf? iirc you just need dbus for plasma itself (but I would have to check)

Concerning slim, have you checked here?:

it seems slim didn’t like exec in .xinitrc back then. Not sure if it’s still relevant.

#slim #plasma5 #freebsd