Slow Desktop loading (Plasma 6)

After update to Plasma 6, my system booting very slow (desktop loads slowly after entering password).


UUID=EC48-40E9                            /boot/efi      vfat    defaults   0 2
UUID=f91fd627-0c14-4151-a0b5-f748226a3093 /              ext4    defaults   0 1
UUID=3be03a4b-f720-4404-9e2c-c065f4d3594b swap           swap    defaults   0 0
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0

systemd-analyze blame:

2.408s fwupd.service
1.842s NetworkManager-wait-online.service
1.582s smartmontools.service
1.047s snapd.service
 831ms udisks2.service
 580ms snapd.seeded.service
 482ms plymouth-quit-wait.service
 481ms plymouth-quit.service
 414ms systemd-journal-flush.service
 381ms gpu-manager.service
 377ms e2scrub_reap.service
 348ms dev-sdd2.device
 345ms neon-apt-mark-kernels-auto.service
 307ms networkd-dispatcher.service
 306ms dev-loop1.device
 305ms dev-loop2.device
 295ms dev-loop6.device
 293ms dev-loop5.device
 289ms dev-loop3.device
 282ms dev-loop4.device
 248ms accounts-daemon.service
 240ms user@1000.service
 226ms boot-efi.mount
 210ms polkit.service
 207ms power-profiles-daemon.service
 207ms dev-loop0.device
 187ms avahi-daemon.service
 180ms systemd-udev-trigger.service
 180ms NetworkManager.service
 161ms lvm2-monitor.service
 159ms snapd.apparmor.service
 152ms ModemManager.service
 151ms switcheroo-control.service
 145ms thermald.service
 145ms systemd-logind.service
 143ms wpa_supplicant.service
 133ms systemd-fsck@dev-disk-by\x2duuid-EC48\x2d40E9.service
 130ms systemd-resolved.service
 127ms smbd.service
 112ms secureboot-db.service
 112ms nmbd.service
 101ms systemd-journald.service
  89ms systemd-timesyncd.service
  86ms upower.service
  80ms rsyslog.service
  79ms apparmor.service
  68ms grub-common.service
  67ms systemd-modules-load.service
  63ms dev-disk-by\x2duuid-3be03a4b\x2df720\x2d4404\x2d9e2c\x2dc065f4d3594b.swap
  63ms systemd-udevd.service
  61ms keyboard-setup.service
  58ms cups.service
  48ms fwupd-refresh.service
  45ms modprobe@drm.service
  43ms i2p.service
  36ms systemd-tmpfiles-clean.service
  36ms packagekit.service
  24ms snapd.socket
  24ms grub-initrd-fallback.service
  23ms plymouth-start.service
  19ms alsa-restore.service
  19ms systemd-tmpfiles-setup.service
  17ms systemd-binfmt.service
  16ms dev-hugepages.mount
  16ms snap-core22-1122.mount
  16ms dev-mqueue.mount
  15ms snap-core22-1033.mount
  15ms sys-kernel-debug.mount
  15ms systemd-tmpfiles-setup-dev.service
  15ms snap-bare-5.mount
  14ms snap-gnome\x2d42\x2d2204-141.mount
  14ms sys-kernel-tracing.mount
  14ms systemd-sysctl.service
  13ms snap-gtk\x2dcommon\x2dthemes-1535.mount
  13ms systemd-sysusers.service
  12ms plymouth-read-write.service
  11ms kmod-static-nodes.service
  11ms user-runtime-dir@1000.service
  10ms systemd-remount-fs.service
  10ms snap-mysql\x2dworkbench\x2dcommunity-12.mount
   9ms modprobe@configfs.service
   9ms systemd-update-utmp.service
   9ms proc-sys-fs-binfmt_misc.mount
   8ms snap-snapd-20671.mount
   8ms systemd-random-seed.service
   7ms modprobe@fuse.service
   7ms nvidia-persistenced.service
   6ms console-setup.service
   6ms openvpn.service
   5ms systemd-update-utmp-runlevel.service
   5ms systemd-user-sessions.service
   4ms rtkit-daemon.service
   3ms setvtrgb.service
   3ms tmp.mount
   3ms ufw.service
   2ms modprobe@efi_pstore.service
   2ms sys-kernel-config.mount
   2ms sys-fs-fuse-connections.mount
  32us blk-availability.service

Result of blkid command and fstab strings UUID’s the same, but EFI partition UUID’s is different.

How to fix it? Change UUID of EFI partition?
P. S. OS: KDE Neon Testing Edition

UPD: I changed UUID in fstab to correct from blkid, nothing happens.

Try updating to the final release; I think this is an issue we just fixed like yesterday.

Hi! Updated now, after entering password desktop loads ~26 seconds.

See what journalctl says, with an eye open for bluetooth (bluez) timeouts…

Had similar problem after changing desktop background image to solid black color. It was 100% reproducible.

After update KDE Neon to plasma 6, the desktop needs more than 50 seconds to load.

Any ideas?

Logging in still takes very long in KDE neon (yesterday’s release) - both after upgrading and after a fresh installation.
And it doesn’t matter if X11 (there the delay happens after the splash screen when one can already see the wallpaper) or Wayland (there the delay happens during the splash screen).

I can corroborate this, too. My Neon Unstable on a weaker laptop logs in faster, too.

Could anyone that has the slow desktop loading, please upload a journald log?

Maybe go to ~./cache and remove everything or put it in an subfolder like “old” or something. Start the system on my system it worked

I would be happy to do this but I’m not tech savvy. I know to use journalctl -b to get the log since last boot; how do I save it to a file and where should I upload it?

Clearing .cache as suggested by the next user did not help in my case.

Start a terminal (Konsole), enter the command to redirect output to a file:

journalctl -b > ~/journal.log

The journal output will be in the “journal.log” file.

Thank you! And would you also please suggest somewhere appropriate to upload it? Many thanks in advance.

You can either use a pastebin service like or

Or create a bug report and upload your .txt file there.

Here my journal.log: journal.log - Google Drive

1 Like

Thanks, Ill see if I can find anything. One thing I forgot to asks:

Does the slow boot also happen for a newly created user?

I just created a new user and yes, also happens.

I noticed that it’s not necessary to reboot to replicate de problem. Just logout an login.

Here you have a part of my journal log: logoff.txt - Google Drive

At 19:32:00 I just pushed enter to confirm my password and login. After 32 seconds of black screen with plasma logo, the desktop finished to load.

Long shot: can you check if xdg-desktop-portal-gnome is installed? If yes please remove it and see if it helps.

Someone posted a possible workaround: 482082 – Plasma takes an extra 33 seconds to start after entering password and logging in when choosing the Breeze Splash Screen - KDE / Plasma 6

Check if this works for you.

First thing I do after a Plasma/Frameworks/Gear upgrade: deleting .cache/* … :wink:

And nothing extraordinary in the log files either…


  • xdg-desktop-portal-gnome is not installed.

  • Disabling the splash screen makes no difference in both X11 and Wayland for my system - logging in is still slow (I also tried new user accounts, of course).

Well, I will wait and see, I guess - KDE neon is a test installation only for me anyhow, so I don’t have to work with it.
But I will keep trying different things with Plasma 6 when I have the time. :slight_smile: