"Software sources" tab/section missing in discover

Just installed kubuntu 24.04. “Software sources”, the link that opens "software-properties-qt from discover settings is missing from the ui. Any help would be appreciated.

Is it there if you click the three-dot button in the top-right corner?

I upgraded from Kubuntu 23.10 to Kubuntu 24.04 LTS this morning, and I too, have this issue with Discover. And no, clicking on the three-dot button only presents a menu with:

Submit usage information
Configure feedback…
Configure Updates…

This is the case on both my desktop PC and my laptop, both having been upgraded to Kubuntu 24.04 LTS from Kubuntu 23.10.

When running Kubuntu 23.10, Discover didn’t have this issue.

software-properties-gtk and software-properties-qt are installed. If I launch software-properties-gtk (sudo software-properties-gtk), I’m prompted for my password and then Software Properties GUI is presented and functional. There is a problem with Discover.

Added:
As a test, I renamed /etc/apt/sources.list.distUpgrade to /etc/apt/sources.list, which is what it was before the upgrade to 24.04 LTS. I launched Discover and clicked on Settings, and the content then shows as expected. The issue is in Discover, as the application software-properties-gtk sees the new .sources files just fine.

This seems to indicate that Discover isn’t able to handle displaying sources after Ubuntu’s move to using deb822-formatted ubuntu.source files placed in /etc/apt/sources.list.d/, and no longer using an /etc/apt/sources.list file.

You should file a bug report on it.

I did. See 487453 – Discover doesn't see/use the new /etc/apt/ubuntu.sources file, or any .sources files in /etc/apt/sources.list.d and doesn't present the Software Sources access button