[SOLVED] Always open newly run applications on CURRENT virtual desktop


MX-Linux 23.1 (based on Debian 12.2), kernel, i7 Intel cpu, 15.4Gb ram, 4Gb swap, Plasma 5.27.5


6 Virtual desktops. I usually open konsole in 1, email in 2, browers in 3/4 using 5/6 for other things. I OFTEN open SublimeText in any of those desktops depending on need. Sometimes I open browsers, etc. in a desktop other than the last desktop they were opened in. Which leads to my “issue” - KDE Plasma remembers the last desktop in which an app was running, and the next time one runs that app, KDE Plasma “helpfully” opens it on that last desktop.

I very much want to stop this from happening (it is beyond frustrating to continually have to righ-click on the Task Manager icon for the app I just opened and navigate to “Move to Current Desktop”). But how? I can find no exposed setting that tells KDE Plasma to do what it is doing. I’d be willing to do this application by application if, for example, I could create an Application Rule to do this, but, alas, for “Virtual Desktop” the only options are ALL desktops (not what is desired) or any one of the existing desktops. What I most want is an item on this dropdown that says “Current Desktop.” Unfortunately, that is no such option.

Anyone have any idea how to do this?

They always open in the current virtual desktop for me. How do you open those programs? Are you using activities?

No it does not and it never did. You have to actually assign which desktop you want a particular app to open on. Meaning if you are on your browser’s desktop, close the browser, switch to another desktoip opening your browser will open it there unless you assigned it to open on the desktop you have for your browser.

Interesting … I’m a retired 30-year IT guy, so I would hope that gives me the experience to accurately describe what I see happening. For example.

  1. Six virtual desktops. Firefox is open in Desktop 4, this browser I’m using to type this response. I have the KDE panel at the bottom and on it are some applications which I’ve added to it (not to the TaskBar, but as widgets). One of these is SublimeText.
  2. If I click on the icon for SublimeText, the application opens in Desktop 5 NOT Desktop 4.
  3. The Taskbar shows an object for SublimeText in the taskbar I see in Desktop 4
  4. If I click on it, I’m moved to Desktop 5 with SublimeText focused.
  5. To get SublimeText on Desktop 4, I have to right-click on the taskbar object, and from the menu that appears I must select Move to Desktop > Move to Current Desktop.

If I restart the computer, KDE’s Remember Session kicks in (since that is configured) and apps open on the desktop they were last open in. But that’s not what this is. Following the above, if I move SublimeText to Desktop 4, then close it, and I move to Desktop 3 and try to open it again, it opens in Desktop 4 not Desktop 3 (nor, I add, in Desktop 5, so there is not, I’d think, any “assignment to a desktop” as SkyBorg mentions)… I think that this means that there is a “moving assignment” (using SkyBorg’s terminology), or an “always remembering assignement,” which is why I used the language I used in my OP.

Do I understand the two of you, that for you this does NOT happen? In describing what I see I may have used imprecise terms that cause misunderstanding, but I assure you that what I describe is in fact what I see happening. It may be that this is an MXLinux “feature,” since that is the distro I use, but I started with KDE’s forum. I’ll cross post my “issue” on the MXLinus forum as well.

Thanks to both of you for taking the time to reply.

1 Like

So far I have not been able to reproduce your issue. But I only use 2 virtual desktops and only 1 monitor.

First thing I recommend you to do is create a new test user and see if you can reproduce with the default settings.
If you can reproduce we need to look at your settings.
If not it gets harder but we should be able to figure it out(hopefully :stuck_out_tongue: ).

So … after pretty exhaustive testing both with a new account and my “old” account, I must rescind my “it’s a KDE” issue statement. Only two apps exhibit this behavior. It’s a Firefox and Sublime-Text issue. The reported behavior ceased for Firefox in the new account, but continued for Sublime-Text. Back in my regular account I renamed the Firefox ./mozilla folder and the behavior ceased for Firefox, yet continues for Sublime-Text. I copied my extensions from the old Firefox folder to the new one created on first running Firefox, and the behavior reappears. So, now have deleted the old .mozilla folder and am using a newly created one. Mea culpa on generalizing the behavior of two apps to all apps (but guess what are two of my most frequently used apps? Yep, Firefox and SublimeText, so their frequent use mislead me). Why in the world, though, should Sublime-Text do this? I will investigate if is has any kind of “session” feature that may contribute to this very annoying behavior.

Thanks to the two of you for responding.

1 Like

That’s odd. Are you using Wayland or X11?

Does this help?

BINGO! We have a winner. Why anyone would think that ST preferences for “workspace” relate to KDE’s Virtual Desktops is anyone’s guess, but that did in fact “correct” ST behavior. It now opens on the Current Desktop. I bow to your superior search capabilities (I have searched for some time, but you seem to have used the correct search terms to fine the correct solution). Thank you.

Happy to help!
Actually I only found it because you helped me so much with your detailed description of your problem and very good follow ups posts.

Please remember to mark your issue as solved if you are happy with the answer!

1 Like