[Solved] Application Icon still persists in menu after uninstalling it

This is like a pretty small/insignificant issue. But I installed some third party application (firebird-nspire on AUR) and the icon persists across restarts after uninstalling it. The thing is, its a blank icon and it points to an empty or non existent file.

Ive posted the a pic here for more information. The applications directory in /usr/local/share doesn’t even exist since I don’t have any globally installed apps so I don’t understand why this icon isnt gone after restarting my system.

  1. The application im referring to is Firebird Emu and you can see how it has an empty icon in the first pic (edited)
    Again its not some critical issue but its still irritating for that to show up

Ive run a global search from root for files with that name or containing anything similiar and come up with nothing so I don’t get why it persists through restarts of my system. For context, Ive fully removed all files related to that firebird packages from all places including the cache folders.

I added that ghost icon to my desktop and it shows it to be a nonexistent file. I’m very sure this is some bug with the way kde cache’s the file icon.

It’s not a huge critical issue to my system but its pretty critical to my OCD lol.


Here is the info for where that desktop file is. The applications folder nor the file does not actually exist.

if you are using apt you can try sudo apt purge [pakage] and it should remove all your /home config files.

if the package doesn’t clean up properly you can go to ~/.local/share/applications/ and just delete the icon.

sudo rm /usr/local/share/applications/org.firebird-emus.firebird-emu.desktop
sudo rm /usr/local/share/icons/hicolor/512x512/apps/org.firebird-emus.firebird-emu.png

I find .desktop files at /usr/share/applications/
and ~/.local/share/applications

I don’t see a location for /usr/local/share/applications because it doesn’t exist.

I don’t see a location for /usr/local/share/applications because it doesn’t exist.

Some Arch or AUR packages install their stuffs in /usr/local/share/applications

Screenshot_20240126_171402

1 Like

I tried everything you could think of like clearing the yay cache + restarting, removing every possible firebird-nspire file, etc which all didn’t work.

After managing to fix it later on, I believe the issue is definitely some sort of bug with the way kde cache’s/stores the desktop file. What I believe to be the case is that some content of an internal config file probably had the info that this firebird application exists even when all the files related to it were deleted so I had to attempt to get kde to rewrite that internal file. This could explain why that icon persists across restarts and hopefully help others in the future until this bug is addressed.

I managed to fix it by doing some sketchy stuff. I created another random file in that same directory (/usr/local/share/applications) which I believe refreshed kde’s caching since it did remove that firebird icon entry from the menu completely. I then deleted that created file again as well as the applications directory (the directory only had firebird so it would’ve been empty otherwise). I restarted and it seems to have been fixed.


You can see how it no longer shows up in the education section nor when I search ‘firebird’.

I really appreciate all your guys’ help and just wanted to give an update about this.

That being the case, I bet running kbuildsycoca5 would have fixed the issue.

You’'re on Plasma 5, right? Not the Plasma 6 RC? If the latter, then it’s likely caused by a recently-fixed bug.

Yes I am on Plasma 5. I definitely didn’t know about that command before and will keep note of it if I run into that problem again in the future! I also look forward to the release of Plasma 6 as well.

Thanks. You may be running into variant of 465646 – Run kbuildsycoca5 automatically upon manual changes to files in ~/.local/share/applications, but for a different directory that needs to be watched. Can you find out which exact directory the app’s .desktop file ended up in?

Another possibility is that you’re out of filesystem watches, so the folder that the .desktop file got created in was being watched properly, but the system didn’t have the resources to notice the addition or removal. Installing kde-inotify-survey can help detect and fix this problem.

i get a bunch of these lines

kf.service.sycoca: The menu spec file ( "" ) contains a Layout or DefaultLayout tag without the mandatory Merge tag inside. Please fix it.

no idea what to “fix”