Solved: Kmail does not show content of e-mails

I have done a re-install of openSUSE Tumbleweed after trying out Fedora. I’m now busy setting up Kontact, including Kmail. In the Kmail screen I do see e-mails in the message list (send and receive work already) but when I click on an email I don’t see the content of that mail in the preview area. It is totally empty. I can switch been plain mail and HTML mail but that makes no difference.

Who has an idea what may cause this?

Some info about my system:

Kernel: 6.3.1-1-default
Plasmashell: 5.27.4
Kontact: 5.23.0 (23.04.0)

inxi -F
  Host: localhost-live Kernel: 6.3.1-1-default arch: x86_64 bits: 64
    Desktop: KDE Plasma v: 5.27.4 Distro: openSUSE Tumbleweed 20230504
  Type: Laptop System: MEDION product: E15302 v: N/A
    serial: <superuser required>
  Mobo: MEDION model: NS15AP serial: <superuser required>
    UEFI: American Megatrends v: AP618_MED_V0.13.2_M00P1T0G0 date: 11/18/2020
  ID-1: BAT0 charge: 43.6 Wh (96.9%) condition: 45.0/45.0 Wh (100.0%)
  Info: quad core model: AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx
    bits: 64 type: MT MCP cache: L2: 2 MiB
  Speed (MHz): avg: 2176 min/max: 1400/2100 cores: 1: 2756 2: 2766 3: 2441
    4: 1339 5: 1366 6: 1231 7: 2759 8: 2755
  Device-1: AMD Picasso/Raven 2 [Radeon Vega Series / Radeon Mobile Series]
    driver: amdgpu v: kernel
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.1 driver: X:
    loaded: modesetting unloaded: fbdev,vesa dri: radeonsi gpu: amdgpu
    resolution: 1: 1920x1080~60Hz 2: 1920x1080~60Hz
  API: OpenGL v: 4.6 Mesa 23.0.3 renderer: AMD Radeon Vega 8 Graphics
    (raven LLVM 16.0.2 DRM 3.52 6.3.1-1-default)
  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor driver: snd_pci_acp3x
  Device-3: AMD Family 17h/19h HD Audio driver: snd_hda_intel
  Sound API: ALSA v: k6.3.1-1-default running: yes
  Sound Server-1: PipeWire v: 0.3.69 running: yes
  Device-1: Intel Wireless 3165 driver: iwlwifi
  IF: wlp1s0 state: up mac: 34:cf:f6:40:ff:0b
  IF-ID-1: tun0 state: unknown speed: 10000 Mbps duplex: full mac: N/A
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb
  Report: rfkill ID: hci0 state: up address: see --recommends
  Local Storage: total: 476.94 GiB used: 213.76 GiB (44.8%)
  ID-1: /dev/sda vendor: Phison model: S11-512G-SSD-B27 size: 476.94 GiB
  ID-1: / size: 39.08 GiB used: 9.83 GiB (25.1%) fs: ext4 dev: /dev/sda3
  ID-2: /boot size: 1.9 GiB used: 71.4 MiB (3.7%) fs: ext4 dev: /dev/sda2
  ID-3: /boot/efi size: 49.9 MiB used: 5 MiB (10.0%) fs: vfat dev: /dev/sda1
  ID-4: /home size: 426.68 GiB used: 202.89 GiB (47.6%) fs: xfs
    dev: /dev/sda5
  ID-1: swap-1 type: partition size: 8 GiB used: 987.8 MiB (12.1%)
    dev: /dev/sda4
  System Temperatures: cpu: 57.8 C mobo: N/A gpu: amdgpu temp: 57.0 C
  Fan Speeds (RPM): N/A
  Processes: 368 Uptime: 2h 55m Memory: 13.58 GiB used: 3.98 GiB (29.3%)
  Shell: Bash inxi: 3.3.23

In the openSUSe forum I received this answers which works:

Make sure you have the following packages installed:

erlangen:~ # zypper se --match-exact -is akonadi-mime grantleetheme-lang kcalutils-lang kitinerary ksmtp libopenssl1_1 librevenge-stream-0_0-0 libXfontcache1 pimcommon-lang
Loading repository data...
Reading installed packages...

S  | Name                    | Type    | Version     | Arch   | Repository
i+ | akonadi-mime            | package | 23.04.0-1.1 | x86_64 | Haupt-Repository (OSS)
i+ | grantleetheme-lang      | package | 23.04.0-1.1 | noarch | Haupt-Repository (OSS)
i+ | kcalutils-lang          | package | 23.04.0-1.1 | noarch | Haupt-Repository (OSS)
i+ | kitinerary              | package | 23.04.0-1.1 | x86_64 | Haupt-Repository (OSS)
i+ | ksmtp                   | package | 23.04.0-1.1 | x86_64 | Haupt-Repository (OSS)
i+ | libopenssl1_1           | package | 1.1.1t-3.1  | x86_64 | Haupt-Repository (OSS)
i+ | librevenge-stream-0_0-0 | package | 0.0.5-1.2   | x86_64 | Haupt-Repository (OSS)
i+ | libXfontcache1          | package | 1.0.5-13.1  | x86_64 | Haupt-Repository (OSS)
i+ | pimcommon-lang          | package | 23.04.0-1.1 | noarch | Haupt-Repository (OSS)
erlangen:~ # 

Infamous host erlangen was affected by similar symptoms: Kmail no longer displays message body

Rolling back and forward again fixed the issue with the puzzling side effect of the above packages being now flagged as user installed. Checking zypper logs and journal showed that no user install was performed.

So this thread can be closed.


This fixed it for me, thanks.