[ SOLVED ] Plasma (Wayland) session stuck on a black screen

I’ve been trying to run Plasma Wayland, however upon logging in there is no splash screen and the screen stays black until a manual forced shutdown. I am still able to ssh into the system, and I’ve tested using both proprietary and nouveau drivers.

I am essentially having the same problem with Wayland. If I try to start a Wayland session (rather than an X11 session) on my current main machine, all I get is a black screen. If I try and boot one of the new Live ISOs (which are using Wayland now for the SDDM), all I get there is a blank screen or a locked image. Only option is to force a power off. I get this on two different machines, both using NVidia graphics at the moment, but I also had problems when I was using a Radeon card. I normally use Fedora but also just tried out Neon. I had to do the initial set-up with the dumb video option, then the image would boot, the install went OK, and that would boot from the hard disk but it was using the dumb default 1280x1024 resolution, rather than the correct scaling for my monitor with no option to fix that either. With new versions going to Wayland and leaving X behind these problems are going to quickly become a show-stopper!!!

1 Like

you have to distinguish between Plasma itself (defaulting to wayland but still supporting X11) and the fedora project, who don’t want to ship x11 anymore.

I agree with @Tionisla, X11 will still be supported for a while!

@nishi @ahw609 if you have problems with your wayland session please report that to your distro and/or upload a full journald log.


How do I get some kind of log, or any other information, when all I have is a black screen, no response of any kind, keyboard or mouse, and Alt-Ctl-F? will not even open another keyboard session to log into?

I managed to fix it thankfully, turns out using the KWIN_DRM_NO_AMS=1 variable in /etc/environment I used to have to get wayland working was now causing it to break :v
I’m running on arch installed via their install script with a gtx 1660 super, if that’s important to any future peeps reading this


If switching to a tty is not possible you could try to use the SysRq keys: Keyboard shortcuts - ArchWiki

Usually it is best to report this to your distro since they know best how to solve this kinds of issues. Which distro are you running?

My daily driver is Fedora 38, but I have also tried Neon (latest user version) and have the same issues.

My suggestions:

  • tell which graphics cards you have.
  • try the SysRq keys
  • report to fedora
  • if everything else does not work create a bug report at bugs.kde.org (kwin | wayland-generic)

OK, thanks for the ideas. I will struggle with this again some day, but I think it might be easier if I use a back-up machine so I can try and do things faster and still have my usual access to this and other resources, as well as perhaps being able to ssh into the broken machine. I am getting nervous about testing on my main box! ;'{

That’s fine. Maybe try when Plasma 6 releases.

@nishi please mark your thread as solved.

1 Like

I experienced the exact same issue for months. I thought it was due to a faulty reinstall and opted to just stick to Xorg permanently. Early last week, it dawned on me that the situation was not unique and others had solved it previously.

This article provides a little bit of context and steps to resolve the issue. I was running Debian and followed the results that pertained to me:

I am able to easily boot Wayland now.

With that said, my personal experience is that Wayland has recurring bugs w/ Nvidia drivers that I hadn’t experienced under xOrg (specifically around graphical glitches every other time my desktop went to sleep) so I promptly reverted to Xorg, but it’s nice to know that the option is there for when the switch is permanently hit across distros in the future.