[SOLVED] Preferred://browser does not Seem to Work Properly in Application Launcher and Task Manager

Hi, I just installed KDE on Linux Mint, using the kubuntu-desktop package (yes, I know the actual KUbuntu distribution exists, but I am still interested in installing the kubuntu-desktop on Linux Mint). I have removed Cinnamon after installing KDE through the kubuntu-desktop package. It all seems to be working mostly great. There is one very small issue though. I am not able to add the default browser to the task bar or the “favorites” menu.

For the taskbar: I know I can add a particular browser, such as firefox or chromium to the task bar, but I know that you can also add the system’s preferred browser as a shortcut on the taskbar, which will automatically change when you change your preferred browser. To do this, you would need to right click on the preferred browser icon on the favorites menu and add it to the task bar. Which leads us to our next problem:

For the favorites menu: The preferred browser is not actually showing up in the favorites menu.
Here is an image of the intended functionality:
The thing I am experiencing looks exactly the same, but does not have an icon for brave (or any web browser. I would upload an image of that too, but this forum is only letting me upload one image.)

The file ~/.config/kactivitymanagerd-statsrc seems to have an entry for “preferred://browser”, which tells me that it should be showing up properly, but yet it is not.




I can confirm that clicking on a link properly opens it in the right web browser, and it is properly set in the “preferred applications” settings page.

How can I make the preferred browser functionality work as intended?

I figured it out! Just need to remove the cinnamon configurations and reload the KDE Browser settings:

rm -rf ~/.config/cinnamon
kwriteconfig5 --file ~/.config/kdeglobals --group General --key BrowserApplication "firefox.desktop" #this example sets it to firefox. Change this to your favorite browser.

Source: KDE Plasma 5 - reload kdeglobals or set default browser via command line

1 Like