Suggestion: setting up WireGuard in System Settings, using network name as if name is confusing

When I was setting up a new WireGuard connection, the default network name was provided as “New wireguard connection”.
Later when I tried to save the connection, an notification pops up complaining “invalid interface name”. Later I tried to save the connection with name “wg”, then everything went fine.
ip route shows that KDE uses wg as interface name.
So it’s obvious the connection name is used as WireGuard interface name.

Note:
This problem might affect other VPN connections as well, like OpenVPN (if I’m correct OpenVPN uses virtual interfaces as well).

Suggestions:

  • Add a new option field for the actual interface name
  • Do not close the set up window if the interface name is invalid
    • When I saved the new connection, the set up window is closed and then the notification pops up later. I had to type in all the fields again.

If I’m understanding the bug report correctly, I think this was just fixed today, to be released in Plasma 6.1. See 479179 – KDE Network Manager creates unusable name for wireguard and fails to save

Sounds nice, glad to hear!