Suspend does not disable the screen

Whenever I suspend my laptop (same as going into sleep), the screen locks, turns off, and then turns on and stays this way. I believe the way is should work is that when the laptop goes into suspend, it should lock the screen, then turn off the screen, and keep it off.
The most awful thing about it is that when I close my laptop, the screen turns on the same way and drains my battery, which is obviously not desired.

How can I make my screen not turn on when in suspend?

My install can be considered fresh, since I only recently installed Arch on my laptop and use KDE.

Hi @sv-cheats-1!

I’m having the same issue for several months now but it doesn’t happen all of the time, sometimes suspend/sleep works correctly, other times it doesn’t.

Initially I noticed that when I rebooted my laptop it wouldn’t happen, but if I turned it off and on again it would, but that also wasn’t 100% reproducible over time.

Sometimes when sleep won’t work I hibernate and after resuming, sleep would work again.

Now, if I boot/reboot my laptop and, after inputing my kwallet password to connect to wifi, I immediately put it to sleep, it works and keeps working untill the next reboot cycle. But if I open even a single application (konsole or akregator most of the time) it just won’t go to sleep properly

Since I switched from Slackware to Fedora and it kept happening, I assumed it was some hardware problem or some application interfering but I could never narrow it down (nothing relevant in the logs).

Now that you post the same behaviour maybe it is a bug after all!

I just searched but couldn’t find anything relevant.
I can open a bug report if needed.

My system:

Operating System: Fedora Linux 38
KDE Plasma Version: 5.27.5
KDE Frameworks Version: 5.106.0
Qt Version: 5.15.9
Kernel Version: 6.2.15-300.fc38.x86_64 (64-bit)
Graphics Platform: X11
Processors: 8 × Intel® Core™ i5-1035G1 CPU @ 1.00GHz
Memory: 15.2 GiB of RAM
Graphics Processor: Mesa Intel® UHD Graphics
Manufacturer: LENOVO
Product Name: 81YK
System Version: IdeaPad 5 15IIL05


If you can open a report, sure, go ahead! I previously had Fedora installed, but the issue only started happening when I switched to Arch with KDE, so I believe it’s a software issue.

Some weird behavior definitely happens, because if I open the logout menu via the power button press and select sleep, then everything works as normal, but if I select sleep after pressing the Meta key, the bug occurs. Maybe the way sleep is invoked was changed and that method wasn’t updated across all entry points or something.

@sv-cheats-1 can you explain your bug you again?

Pressing Meta and clicking Sleep works on my Arch/KDE machine (screen locks, turns off and PC goes to sleep).

I don’t understand. Does the screen turn on again or does it not turn off? Works for me on my Tumbleweed/KDE Laptop.

Maybe something inhibits sleep mode? What does systemd-inhibit say?

Also can you please share a screenshot of your Systemsettings->Power Management->Energy Saving ?

@richarson do you still have the same issue?

There was a bug in kernel 6.1 but it should be fixed now?

@Duha yes, I still have the issue.

I’m on kernel 6.2.15 but my system is Intel so I’m not sure if I’m affected by that bug, though the description seems pretty much the same symptoms.

Only I can put my laptop to sleep either with my keyboard’s sleep button, or via Ctrl+Alt+Del and selecting Sleep from the menu.

I’ll try with systemd-inhibit on my next reboot and see if it sheds some light on the matter, thanks.