System freezes if activing Catwalk plasmoid

Hello.
If i activate Catwalk plasmoid in my up-to-date Plasma installation, the system freezes in boot and the main panel does not appear, whether the plasmoid is placed on the desktop or directly on the panel.
My laptop config:
Ideapad 330 AAR 15 with Archlinux Plasma wayland.
Device-1: AMD Raven Ridge [Radeon Vega Series / Radeon Mobile Series]
driver: amdgpu v: kernel
Device-2: N180403f3043 EasyCamera driver: uvcvideo type: USB
Display: wayland server: X.org v: 1.21.1.10 with: Xwayland v: 23.2.3
compositor: kwin_wayland driver: X: loaded: modesetting unloaded: vesa
dri: radeonsi gpu: amdgpu resolution: 1366x768
API: EGL v: 1.5 drivers: radeonsi,swrast
platforms: wayland,x11,surfaceless,device
API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 23.3.1-arch1.1
renderer: AMD Radeon Vega 3 Graphics (radeonsi raven LLVM 16.0.6 DRM 3.54
6.6.7-arch1-1)
API: Vulkan Message: No Vulkan data available.

So this is Arch

The Catwalk plasmoid did not work in openSUSE Tumbleweed (Plasma 5.27.8/9 and Frameworks 5.111/12 were the versions when I tested it) for me either - and also has not for some time with earlier Plasma and Frameworks versions.
The behavior/effects were the same ones that you describe and it did not matter if I used the Plasma panel or a Latte Dock panel.

It works absolutely fine for me in Kubuntu 22.04 (Plasma 5.27.10/Frameworks 5.104), Debian 12 (Plasma 5.27.5/Frameworks 5.103) and TUXEDO OS 2 (Plasma 5.27.10/Frameworks 5.113 - the same version numbers as in a current Arch).

All in X11, no Wayland.

1 Like

PS: Perhaps it would be a good idea to contact the author, as this is a third-party plasmoid.
To be honest I am too lazy and this plasmoid is too unimportant for me to do it. :wink:

Thanks for your fast reply.
I confirm that the same thing happens when loging with: Xorg.

Interesting new observation:
As soon as I set the Plasma Panel to “floating” and add the CatWalk plasmoid in Kubuntu 22.04 (Plasma 5.27.10/Frameworks 5.104) plasmashell begins using 100% of CPU and is stuck.
Same behaviour as in openSUSE Tumbleweed some months ago (but there it was with a floating Latte Dock panel).

As soon as I “defloat” the Plasma Panel in my Kubuntu 22.04 I can add the CatWalk plasmoid without problems.
Strangely enough it works with TUXEDO OS 2 (Plasma 5.27.10/Frameworks 5.113) all the time - whether the Plasma Panel is floating or “defloated”…

PS: I wrote a note to the author.

2 Likes

Good day. Thanks for feedback. I will test catwalk on your system (on VM) and try to catch any errors.
Have a nice day!

2 Likes

True, after I disabled the floating panel, the system worked normally, excellent observation.
PS: Even when I reactivate the floating panel and reboot, everything is fine.

Glad there is a workaround for you!
I just tested the method of your “PS” with Kubuntu 22.04 (Plasma 5.27.10/Frameworks 5.104) and the Plasma Panel: unfortunately plasmashell is stuck again after a reboot.
I think I will also test this with openSUSE Tumbleweed and defloating/floating the Latte Dock panel, but I don’t have too much hope that your workaround will work there either.

PS: No, plasmashell also gets stuck in openSUSE Tumbleweed (Plasma 5.27.10/Frameworks 5.113) when I try to use the CatWalk plasmoid in a Latte Dock panel (floating or not does not make a difference).

1 Like

I tried the process after a new installation of Arch Linux, and after activating the plasmoid, no hung or crash occurred, but when I try to enable floating panel, the system hung and does not respond.

1 Like