System monitor does not detect discrete GPU anymore

I have a laptop with hybrid gpu. AMD iGPU and Nvidia dGPU.
System monitor used to be able display memory usage for both gpu. Lately it no longer does so
One thing I did change some time ago was to change to proprietary driver.
How do I make KDE see the 2nd gpu again?

I have the same issue with an Nvidia dGPU and an intel integrated, after I update my kernel and the Nvidia driver broke.

Can you run in your terminal the command lsmod | grep nv ?

If it doesn’t show any Nvidia driver, that could be the problem.

~$ lsmod | grep nv

nvidia_uvm 3489792 0
nvidia 62705664 10 nvidia_uvm
nvme 65536 3
nvme_core 237568 4 nvme
nvme_common 20480 1 nvme_core

So this should mean the driver is loaded, correct?
One thing that has also been a problem is the inability of Davinci Resolve to detect the GPU in Archlinux when I can use Resolve in other distro

On my system, after re-installing the Nvidia dkms driver for the new kernel - I also can’t get the GPU sensors to work. I’ll look more into it.

After I figured that my NVidia Optimus setup wasn’t actually working because I installed the NVidia “open” driver - that didn’t actually work because it is a “data center only driver” and in order to use it on “non-data center GPUs” you need to setup a /etc/modprobe.d/ file with options nvidia NVreg_OpenRmEnableUnsupportedGpus=1 - now that it works, and nvidia-smi sees the device, all the GPU system monitor sensors see it just fine.

That being said - now my system can’t sleep. This may or may not be related.