System Notification Helper annoying repetitive reboot request

I get multiple System Notification Helper: A system restart is required…

This is even more annoying than Windows Update (though thankfully this one won’t automatically reboot the machine for me, it will pester me insistently until I do).


you also have updates available… so maybe do those and then reboot?

or you can turn off notifications using the system tray icon “do not disturb” mode…but you should eventually take care of this and then it will will stop “nagging” you.

you can also set discover to only check for updates less often, or to not automatically allow security updates if you really want to hang it out there.

But surely it would suffice to notify me once, rather than continuously at a rate of once per second or two. Often I have something I’m working on, and don’t want to update until I’ve finished. But with a once-per-second nag, this makes the machine unusable until I reboot.

Yes. This is either already fixed in a upcoming release or will be fixed (likely). If you want to make sure you can look if you can find a bug report for this.

For now, as a workaround, you can disable the notifications.