Systemd mounted files marked as locked (but only for KDE apps)

I am using Systemd to mount my network shares (cifs) from a NAS for years now. After upgrading Opensuse Tumbleweed to Plasma 6 some weeks ago I am experiencing a weird issue which is only affecting KDE apps.

As shown below, all files/folders in the shared folders show up as “locked” (literally).

Create Folder is deactivated and I cannot do anything with the files.
Also Digikam, which has the sample folders linked, thinks the network-share is currently not availble.

But every non-KDE-tool is fine with the share. Darktable can work with the files just fine, I used cp to copy some stuff over etc.

As far as I know, KDE apps use the kio framework for file-stuff. It seems there is a bug there, but before opening a ticket I wanted to ask here if there are other options I could try.

Here’s my share-config

Description=NAS Photo Share



My user is in the correct group

$ id -G    
1000 100 xxx yyy zzz

Plasma-Version: 6.0.3

Can you share the output of:

kioclient stat /mnt/netshare/loki/pictures/ 2>/dev/null

And where is the UID?
What is the output of ls -l /mnt/netshare/loki/pictures and ls -ld /mnt/netshare/loki/pictures
Also, open a terminal in Dolphin and check the credentials through there.

I have a feeling it is just the credentials being set to root.
It should work with only group credentials since 0770, but you never know with cifs.

Thanks for helping out.

$ kioclient stat /mnt/netshare/loki/pictures 2>/dev/null
NAME                  pictures
SIZE                  0
FILE_TYPE             0040000
DEVICE_ID             112
INODE                 256
MIME_TYPE             inode/directory
ACCESS                0770
MODIFICATION_TIME     Mon Jan 8 15:29:36 2024
ACCESS_TIME           Mon Jan 8 15:29:36 2024
CREATION_TIME         Sat Jan 5 19:55:10 2019

With regards to permissions: since everything works in terminal or GTK apps I assume they are setup correct. I did check the permissions and all looks good.

$ ls -l /mnt/netshare/loki/pictures
drwxrwx--- 2 root users        0 16. Mär 23:36  2003
drwxrwx--- 2 root users        0 16. Mär 23:36  2008
drwxrwx--- 2 root users        0 16. Mär 23:36  2010
drwxrwx--- 2 root users        0 16. Mär 23:36  2011

users is groupid 100

$ls -ld /mnt/netshare/loki/pictures
drwxrwx--- 2 root users 0  8. Jan 15:29 /mnt/netshare/loki/pictures

And it works if you for example rename a file in a terminal without using sudo?

What about if you open a terminal in Dolphin, do you end up in the correct location in the terminal or are you under a /run/... directory? (press f4 in Dolphin)

non-root action

$ cp notes.txt /mnt/netshare/loki/pictures 
$ ll /mnt/netshare/loki/pictures | grep notes
.rwxrwx---  193 root 15 Apr 09:29 notes.txt

opening terminal in Dolphin when inside the share is showing the correct location. no /run/...

Seems like a dolphin bug then.

You could add the credentials in Dolphin too (right click bar, other > credentials/owner/group) to see they are the same.

I do not know much about kio, but that seems odd, if the directory was empty, sure… But then again, kio with cifs, I have very little knowledge.

Thanks for the insights. I guess I will open a bug.

I just tested by setting root as owner and my group, credentials 770, and yepp, I can not interact with it in Dolphin either (other than reading contents).
This is confirmed.

I cannot reproduce this issue with Dolphin 24.02.2:

$ ll qt6.3 -d
drwxrwx--- 1 root docker 8.0K Apr 15 12:45 qt6.3/
$ ll qt6.3 | head -n3
total 392M
-rw-rw---- 1 root docker  29K Mar 28 12:21 libqt6core6_6.6.3-0xneon+22.04+jammy+stable+build90_all.deb
-rw-rw---- 1 root docker  29K Mar 28 12:21 libqt6gui6_6.6.3-0xneon+22.04+jammy+stable+build90_all.deb
$ id
uid=1000(odeda) gid=1000(odeda) groups=1000(odeda),134(docker)
$ xdg-open .

@Brainspiller , @bedna - maybe you are using an older version where that problem was not fixed yet?

Since KDE released 6.1 last Friday and I am still on 6.0.3 I will wait and test with the latest.
As of today the release has not yet landed in Opensuse Tumbleweed, but I guess it will soon.


@Brainspiller what is the version of Dolphin that you use? Dolphin is part of KDE Gear and not part of the Plasma release, so if you might already be running an up to date version.

Confirmed, 6.1 just dropped for me and after upgrade this issue is solved.

Still not letting me update the information on owner/group by pressing f5 though, I have to restart Dolphin.
But that is not present on pure arch only on manjaro for me. Not sure where the error lies. (and I don’t really care)

It had been reported: 483436 – Incorrect display of file icons (thumbnails)

And I fixed it, this was a regression on a change I did.

Still not letting me update the information on owner/group by pressing f5 though, I have to restart Dolphin.

I don’t reproduce that, I can change group and the view refreshes after F5.

Dolphin Version: 24.02.1

@Brainspiller according to @meven this issue was fixed in the KIO library in KF6 and to my understanding should be part of the KDE Frameworks 6.0 official release, but possibly the fix has only landed in 6.1. I’m currently running kf6-kio 6.1.0+p22.04+vstable+git20240415.1342-0 from Neon, where this issue does does not exhibit.