T-Online Account - Incomming mails (KMail)


For my daily work I’m using GNOME and happy with it.
I want to take a look to the new KDE, I’ve read a lot about good and interesting things about Plasma 6.
I wanted to see the integration of Kmail (and canlendar) to the desktop (“similar” to GNOME Evolution).

I tried to configure Kmail, but I don’t get mails shown in my Incomming Mailbox, but mails in the subfolders are shown.

Bildschirmfoto vom 2024-05-29 19-47-39

Configuring Thunderbird (on KDE) worked as I expected, but I didn’t get the calendar “connected” to the tray calender widget.

Any idea why KMail didn’t work as I expected?




First, welcome to the KDE Discuss forums.

Looking at your IMAP configuration to Tonline, it seems to be a little bit weird – compared to 1&1 and IONOS –

  • You have sub-folders below the Inbox – „Posteingang” …

Here’s what I have for my Bug Reporting (1&1 @online.de) e-Mail account –

Have you followed the Deutsche Telekom instructions for setting IMAP access to the @t-online.de e-Mail accounts? – <Wie heißt der Posteingangsserver/Postausgangsserver für meine Telekom E-Mail-Adresse?>


BTW, with 1&1 and IONOS I currently have a total of 8 IMAP e-Mail accounts active with KMail.
And, I have 3 local folders – the main local folder has 2.6 GiB of local e-Mail – dating back to 2001 …
And, I have archived e-Mail dating back to 1999 – family matters …

I’ve briefly looked at other e-Mail clients but KMail has been my default e-Mail client since SuSE Linux 8.1– 2002 – the e-Mail pre-2002 was via MS Windows and the T-Online client offered at that time …

Thanks for the answer. I double checked it and for me it looks the same.
Same issue in Merkuro Mail.

I installed Thunderbird, configured it and it loaded/showed all mails.

Last year I tried KDE on an old machine and Kmail could receive my mails.
After the mega release I installed it in a VM and on an old system again. Now I didn’t get it to work.

Here a screen shot from “Evolution”


Do you have KWallet and the default wallet “kdewallet” setup correctly?

  • Are the passwords for the T-Online servers correctly stored in the following “kdewallet” folders?

  • imap

  • mailtransports

Further information here – The KWallet Handbook
And, here – <ArchWiki – KDE Wallet>

Please note the ArchWiki point that, KWallet will only open the “kdewallet” automatically at login if, the Wallet is encrypted with Blowfish and, the password is the same as the user’s login password.

@Franken14679 :
Yes, there is an entries in the kdewallet folders “imap” and “maitransports”.
The password in the folders are correct…


Then, it could be a specific Plasma 6 KMail issue with T-Online.

Sorry, but, you’ll have to raise a KDE Bug Report to get this resolved – <https://bugs.kde.org/>

  • You’ll also have to include a Network Trace – Install “Wireshark”; add yourself to the “wireshark” group; start Wireshark and begin monitoring the box’s network interface; refresh the T-Online IMAP Inbox and check the network trace.
    You’ll probably have to filter the network traffic to only show the relevant handshaking between the KMail client and T-Online.

And, your issue with Calender synchronisation – with the KDE Plasma Kontact suite, “KOrganizer” –

With the KDE Plasma KOrganizer the setup should be something similar.

There is another post here:

> [Kmail does not access directory with emails in new system](https://discuss.kde.org/t/kmail-does-not-access-directory-with-emails-in-new-system/6828)

This looks like “my” issue.
But I’ll raise a bug report.


Not really – they’re discussing what KMail is doing with the directories it creates in ‘~/.local/share/’ …

For example, on this system, in ‘~/.config/’ the contents of the “akonadi_maildir_resource_?rc” files is as follows …

 > cat .config/akonadi_maildir_resource_0rc
 > cat .config/akonadi_maildir_resource_1rc
 > cat .config/akonadi_maildir_resource_2rc

In other words, the first local mail directory KMail creates (the directory numbered “0”) is ‘~/.local/share/local-mail’ – in the KMail user interface, that directory is named “Local Folders” / »Lokale Ordner« …

  • In addition, once the disk block assignment for that directory has reached a re-determined size, an additional “hidden” local directory is created and, all local e-Mail files are moved to that new directory – ‘~/.local/share/.local-mail.directory/’ …

For my case, the Akonadi Maildir resources 1 and 2 are local resources I’ve created in addition to the “Local Folders” resource.

In computing, in general, when counting, the counting often begins with the integer “0”.


Are you absolutely certain that,

  1. The IMAP resource is configured to use SSL and IP Port 993?
  2. The SMTP resource is configured to use SSL and IP Port 465?

to your questions:

  1. IMAP => SSL and port 993
  2. SMTP => SSL and port 465
    Authentisierung: Klartext (Authentification: Plain)

Same settings SSL and port in Thunderbird (under KDE) are working.

Thanks for clarifying!


Your issue may be IMAP “Server-side subscription” – right-click on the IMAP object above the inbox – in your case „Imap (secureimap.t-online.de)” – and choose “Server-side subscriptions” »„Serverseitiges Abonement …”« –

  • Make sure that, everything is selected – including the Inbox itself and the sub-folders …
    Press the “Check for new mail on the server(s)” – »„Nach E_Mail sehen”« – button.

Thanks! Now I see the incoming mails in KMail.
Merkuro Mail still does not show the incoming mails.

I’ll keep on testing Plasma and Gear!


I was unaware that, one can create sub-directories below an IMAP Inbox and an IMAP Outbox –

  • Now done with both 1&1 an IONOS e-Mail accounts – everything fine with KMail, 1&1 Android Mail App and, the Web Interfaces.

One learns something new every day … :smiling_imp: