That's quite a bold default, Skanlite

Thought this was quite funny — skanlite decided to default to 16557 mm today, which equates to 15 metres. That’s quite the bold default — my scanning apparatus isn’t quite that impressive!

Luckily, a restart fixed it.


you seem determined to make this particular scanner app work, any reason why?

@skyfishgoo, the sole alternatives I’ve tried which have been of any use to me have been Scanner - Quick and Easy Document Scanning - Official app in the Microsoft Store and Purchase VueScan for macOS, Windows, and Linux. However, the former is for Windows 10+, and the latter costs a lot of money (and its developer isn’t interested in upgrading its very outdated WxWidget GUI).

I’ve also tried its replacement, skanpage, from However, its GUI is a significant downgrade:

  1. I can’t modify any preferences without a scanner already connected. This is because although some preferences are, weirdly, still in a separate window


    most preferences are in a sidebar:

    I don’t understand why they’d put them there, but if they’re going to by default, why doesn’t it use the same standard panel implementation that konsole and dolphin do, which allows the user to reorganize it and separate it into a window if desired?

  2. The toolbar doesn’t adhere to my kcm_style icon presence preference:

    as is visible in other screenshots of its GUI.

  3. It tends to use pages rather than windows when doing things like searching for scanners:

    1. versus

    which limits my ability to see and do multiple things simultaneously.

It’s also only as buggy as something like #Plasma-Discover is, per 484109 – Discover segfault when interacting with any listing.. I suppose that means that my standards are fairly low currently, but at not wanting to bother to search for alternatives — laziness — is a powerful force.

Maybe it’s worth me trying some of the suggestions at Have you some?

Ironically, this issue too turns out to be rather reproducible, so I’ve filed 484246 – Skanlite randomly detects scanner dimensions as 14 metres wide upon initialization..

this is my first time doing taxes with linux so i def need an app to use with my cannon flatbed scanner.

tried vuescan early on and found it was ultimately too buggy (and expensive) plus it didn’t even uninstall properly for me (could have been my fault)

tried your skanlite and didn’t like how disjointed it seemed with all the separate windows and it didn’t offer a b&w mode for tax documents, also uninstalled.

i do have skanpage installed and it offers a real time preview of the scan result, but it also lacks a b&w mode and generally seems slow/buggy… but it’s otherwise functional and even tho it doesn’t remember my document settings between uses, i keep it around in case nothing else works.

i have the default document scanner installed and it has a simple UI and just seems to work… it has a real time scan result, supports b&w (in text mode) and saves as .pdf but no OCR and is very basic (but reliable).

then i found NAPS2 which has profiles you can save for different types of scans, including b&w… it also does OCR and will save a multipage .pdf with rotate and sort functions… still a bit slow to show the result with no real time preview of the scan but being able to save a profile including the scanner device means that it doesn’t have to hunt for the scanner before scanning each use which saves time, i’ve just has instances where it can’t find the scanner for some reason

overall, i would recommend document scanner for basic just get it done work.

NAPS2 has the potential to be a workhorse if set up properly.

1 Like

@skyfishgoo, many thanks. That’s quite comprehensive. I’ll evaluate Download - NAPS2 when I’ve the chance.


“Default” document scanner? If you’re referring to KDE plasma6’s default, it’s still skanlite, to my knowledge (although it might be skanpage now).

Do you mean Document Scanner – Apps for GNOME by any chance…?

yeah, that’s the one… i guess it was the first one i found/installed so i call it the default.

1 Like

It is the default on GNOME, I think, @skyfishgoo.