Thermal Monitor - Plasmoid showing system temperatures

I’ve created a Plasma 5/6 applet for showing system temperatures on both desktop and panel, using libksysguard/ksystemstats for temperature information (the same backend as the new System Monitor).

It’s brand new, but inspired by the original created by kotelnik/clearmartin - one of my favourite plasmoids.

I started by creating it for Plasma 6, and it might be one of the first unofficial applets targeting it. After polishing it off and porting to Plasma 5, I decided to release it on the KDE Store.


Please let me know what you think!


Well, it sort of works. It shows Nvidia-smi GPU temp of GPU 1 correctly, but only GPU1, even though I have two dedicated graphics cards, yet it shows two nvidia-smi entries in sources, which I assume is for each card. GPU 2 shows the same temp as GPU 1, but GPU 1 always runs hotter as its physically above card 2. It lists ssd temps (and my printer of all things), but then displays “off”, and its not showing CPU or any of the Mobo temps, nor is it showing labels.

Also the drop down menu for sources is invisible. It is either white text on white background, or just plain not present at all, even though you can click on it and it then shows the label… it does not seem to conform to the default dark theme properly. My machine is pretty much stock… I have no heavy customizations or anything going on.

Interesting. If the sensors also broken in System Monitor, or the System Monitor Sensor applet, then these are issues in ksystemstats. If you’d like to help fix them, let me know.

As for the drop-down menu and theming, please send a screenshot so I can see.

It seems to be an issue with Sysmon and applets. I tried adding the GPU page and its showing the same errors. It seems something broke the GPU part of it in 5.27.7, as they were all working fine right up until the last update.

Running nvidia-smi shows the correct values. Psensor shows both GPU’s, correct temps and usage, but it appears the memory usage is being reported incorrectly, and it does not show frequency.

I have run ksystemstats and it says it is loading all the plugins, I have run lm-sensors and added some missing modules, but neither of these things had any effect. I am somewhat less concerned about the GPU usage or temps, and more about the memory usage, leaks, and scheduling (such as ensuring all CUDA enabled devices are performing - IE both GPUs and the CPU in Blender or Resolve).

I tried taking a screenshot of the dropdown list issue, but it seems to disable the printscreen function when its visible. So I took a photo with my phone.

I am happy to help in any way I can as I really miss the ability to quickly reference the GPU state (I have a small display dedicated to telemetry output). All other sensors are performing normally in System Monitor.

Ah - wrong applet, that’s the older applet that inspired this one.

As you can see, the sources also do not show any of the other motherboard/cpu sensors.

I just clicked the link to the KDE store you provided above and clicked “Install” on the webpage. I just tried to compile it from git, but its kicking up this error:

No need to build it. Anything on KDE store you can also install from inside KDE with the “Get New…” buttons. In this case, right click the panel, press “Add Widgets…” then “Get New Widgets…”. The store-listed applet can be found in that menu. It should also appear in Discover.

My bad. I found the right one. It is showing this:


Can you run nvidia-smi dmon -s pucm > out.txt for 10 seconds, cancel it with CTRL+C and send the file out.txt?

It’ll look like this:

oliver@Oliver-PC ~ ❯ cat out.txt
# gpu    pwr  gtemp  mtemp     sm    mem    enc    dec    jpg    ofa   mclk   pclk     fb   bar1   ccpm 
# Idx      W      C      C      %      %      %      %      %      %    MHz    MHz     MB     MB     MB 
    0     21     36      -      1      3      0      0      0      0    405    315   1599     40      0 
    0     21     36      -      1      3      0      0      0      0    405    300   1599     40      0 
    0     21     36      -      1      3      0      0      0      0    405    300   1599     40      0 
    0     21     36      -      0      3      0      0      0      0    405    300   1599     40      0 
    0     21     36      -      0      3      0      0      0      0    405    300   1599     40      0 
    0     21     36      -      2      4      0      0      0      0    405    300   1599     40      0 

The output of this command is used to populate the sensor info internally and it may not be parsed properly with multiple GPUs.

Thanks. Exact output might be important, so if you can upload the file itself somewhere and link me to it, it may help. I’ll see if we can get .txt file upload enabled here too.

Try this:

And again for the output of nvidia-smi --query please.

BTW, thanks for the prompt for Depeche Mode. I am listening to it as we work on this. :smiley:

1 Like

Is “Total Video Memory” available in System Monitor/its sensor applet?

Yes, it shows 4.3GiB, and 2.3GiB (I assume its using millions of bytes (1000), not MBs (1024) hence the larger number than the actual 4/2gb - this has always been the case though, even when other things worked).

It worked before? Do you know what version it broke in?

It seems like the issue is with the constantly queried data (say temperature, usage, frequencies and power) are not being updated on the second device. That Total Video Memory works is good - it means that the devices are mapped properly and that initial information is properly updated.

This problem first appeared with the introduction of NVidia Driver 525 and I think Plasma 5.25 (whatever it was when they released Neon with Ubuntu 22.04 LTS last year). The solution was to revert to driver 515. The issue was white spaces within the output from 525. It was solved for 525 in Plasma 5.27.3 IIRC. The GPU monitoring widgets all ran fine on 515 up until Plasma 5.27.6 when Neon forced an update to nv525 when it updated the kernel to 6.2. The widgets still worked fine with Plasma 5.26.6, nv525, and kernel 6.2, but broke with 5.27.7.