Tiny cursor on high-res screens in some apps

In some applications, the cursor does not scale to match the display scaling on a high-res screen.

Here is an exampe, Betterbird/Flatpak version: Big black left-handed cursor is set in KDE settings as size 64, it displays as intended. Tiny right-handed cursor does not scale with the display.

grafikgrafik

The cursor snaps to changed size when it is moven into or out of the app 's window, or another pane within the app.

I’ve seen this in Betterbird (Flatpak), Treesheets (Flatpak), Back In Time (zypper), YaST package manager (SUSE installer), and probably others I’ve forgotten.

Some web sources assumed this was a QT widget issue.
edit: no, GTK may also be affected, I’ve seen it in Font Manager, too.
edit2: this guy says it may be gone with a proper upgrade, but he’s on Wayland, I’m on X11.

I tried to set the cursor with XCURSOR_SIZE=64 , and and to use QT 6 Configuration tool (with QT_QPA_PLATFORMTHEME="qt6ct" set).
Both settings were in .conf files in a newly created /etc/environment.d/, the working tool showed it was the right place. (The tool does not offer a way to set cursor size as I hoped it would).

How to get the tiny cursor into a usable size?

I think there may be a few different bugs involved across all the application that you noted.

At least for Flatpak applications I think this is issue #740 in the Flatpak github respository, and maybe the workaround suggested there will help.

Thanks! I tried it with some modifications (no /usr/share/cursors/* here) like cp -r /usr/share/icons/breeze_cursors/* /home/user/.local/cursors/, and a some direct settings (flatpak --user override --env=XCURSOR_THEME=Adwaita and flatpak --user override --env=XCURSOR_SIZE=48, from here) but nothing helped.

If it is upstream from Flatpak in Qt or GTK – what do these have in common that a user can fiddle with? Probably too naive a thought…

Maybe try to set XCURSOR_THEME=Breeze? it makes more sense for Plasma.

For Adwaita you’d need to also have the Adwaita theme installed in /etc/X11/cursors/ so make sure that whatever cursor theme you see in the variable is actually installed.

No luck… Thanks for your time in any case!