Touching any video file in my project bin immediately crashes Kdenlive 23.04

The title basically says it all. Any time I click on a video file in my project bin, the program crashes immediately. I can edit my timeline, do all my editing, but if I touch a video file, pooof!

This is preventing me from finishing a time-sensitive project, so any help anyone can provide would be much appreciated.

Not sure if this is a bug or not. Seems like it to me, but not sure.

1 Like

I am not aware of that particular behavior but I know that 23.04 is suffering from some crazy bugs, like corrupted .project files. Some fixes are on their way and even in the nightly builds already.

Until the next release I suggest you stick with 22.12.x unless you desperately need nested timelines.

Hi, if have the same problem here.
First i opened a project from the previous version and saved it as a new project which resulted in crash after clicking any project clip in the folder section (left side).
Then I tried to create en empty file and this works for some time. Then - left click on any project clip in the project list crashes KDEnlive again.

KDE Crashreport was created, but at the end it said ‘there is not enough information for the developer’ and therefore not send.

Try the hotfix 23.04.0a or stay on a previous version.

The devs are aware of the issues/bugs and are working on them. 23.04.1 is due in mid-May …

If you can reproduce the crash please consider reporting it on Some tips on creating a great crash report are here as well: Guidelines and HOWTOs/Debugging/How to create useful crash reports - KDE Community Wiki.

I tried to generate the crash report - but it always said that the information is not enough to be usefull.
Than i have installed the snap version (ubuntu 22.04 LTS) . It comes also as Version 23.04.0 and the problem is gone.

It’s quite possible it was missing debug symbols. The links above help with installing them.


i was to quick )-; - After creating a new project and insertiing more clips, kdenlive crashed from time to time again.
My system is Ubuntu Studio 22.04 and i had included the PPA from kdenlive. With this configuration everything worked fine until i got the update from 22.12.3 to 23.04.0.
If have disabled the ppa now and i have downloaded the appimage for Version 22.12.3 to get my video editing going again.