Touchpad is not automatically disabled while typing

When I write on my laptop, as soon as my palms touch the touchpad, the mouse travels anywhere on the screen and I often see large chunks of text being selected and replaced by what I’m writing at the moment.

I tried to select and deselect “Disable while typing” in the settings, but the behaviour is the same whatever option I use. This is very annoying and considerably affects my productivity.

I’ve been searching the Internet for a solution to this problem, but haven’t found one that’s satisfactory.
I contacted Tuxedo, but they replied saying that «unfortunately we have no influence. This is more a matter for those who provide this feature, be it Xorg or Wayland or the desktop environment programmers. From what I’ve heard, this feature works better under Wayland. But if it doesn’t, then unfortunately our hands are tied.» :worried:

I’ve been using X11, but recently tried Wayland and didn’t notice any significant improvements. I know I can use an external keyboard, but that doesn’t solve the problem when I’m travelling and have to use the laptop’s keyboard.

My operating system is Tuxedo OS 3, based on Ubuntu 22.04.
Is there anything I can do in terms of configuration so that the touchpad detects my palms better when I type?