Trouble shooting Kbackup

The configuration for the included Kup backup for Neon seem very straightforward. I don’t see many references to issues in the forums so I assume that my challenge is due to pilot error. I am backing up to a mounted USB drive with several TB of space and backup seems to connect. However, there is a red badge on the status display.

I would sincerely appreciate any suggestions regarding possible cause.

I am running the following:
Operating System: KDE neon 5.27
KDE Plasma Version: 5.27.3
KDE Frameworks Version: 5.104.0
Qt Version: 5.15.8
Kernel Version: 5.19.0-38-generic (64-bit)
Graphics Platform: Wayland
Processors: 8 × Intel® Core™ i7-4790T CPU @ 2.70GHz
Memory: 15.6 GiB of RAM
Graphics Processor: Mesa Intel® HD Graphics 4600
Manufacturer: HP
Product Name: 410-019
System Version: 1.00

There is lots of space on the destination identified by Kbackup. I am at a loss. I even did a fresh bare metal install and have the same issue. GPT suggested the following but everything seems to check out.

[The red badge on the status display of Kup backup for Neon indicates that there is an error with your backup. [The error could be due to various reasons such as insufficient space on your USB drive, incorrect configuration settings, or a bug in Kup] [You can try checking if you have enough space on your USB drive and if your configuration settings are correct]. [If that doesn’t work, you can try reinstalling Kup or reporting a bug]

Did you find a solution to your problem?

I just tried setting up a new backup plan and I left the name of the “Destination Folder” at its default value, namely “Backups” and the plan would not run and didn’t give any indication why. It took me a while to realise I had to create the named backup folder on the destination device.

I’d certainly recommend reporting this as a bug, software should help users accomplish tasks as efficiently as possible. In this case, check if the folder exists and if not, create it.

Bug 468269

Thanks so much for the solution Paul. :grinning: I can’t believe that I was stymied by something so simple. Also, thanks for reporting the bug. It really did not anticipate that the default directory needed to be created in advance.