Turn off font ligatures in konsole

how do I turn off font ligatures in konsole? or only when konsole is running certain programs like vim. I turned it off in vim but ligatures didnt go away, so the problem is konsole. any help is appreciated.

I don’t think KDE projects support turning on/off OpenType features yet, they just use (some of) the features declared as default in the font file. You cannot change which font features are used on KDE apps as you can, for example, in LibreOffice. If you’re using a monospaced font with programming ligatures, I’m afraid your only option is to switch to another font that does not use programming ligatures.