Turn off screen... and then on again....?

Q1 I want to turn off the screen but not sleep mode, but I want to be reassured that it turns back on with a click of a mouse button or keyboard letter. Does the widget “turn off monitor” actually turn back on!? I know it might be a stupid question but I am afraid something bad might happen. I’m cautious because of other desktop environments I’ve used so it makes me nervy.
Q 2 – does “turn of screen” in shortcut settings turn off and then on again with a keyboard key or mouse as well? I don’t want it to be turned off forever.

Thanks for being patient with me and understanding. I am new to KDE and used it briefly in the past and now I want to use it full time.

“Turn off screen” generally means just the display and no system sleep states. This is handled by KDE’s power management service, PowerDevil, and achieved by sending a DPMS Off command to each connected display.

The service listens for mouse or keyboard activity (software could theoretically also simulate activity) and turns the display back on when the user is active again.

Display off by itself won’t put your system to sleep. But watch out for your System Settings configuration in Energy Saving, if you have it set to automatically suspend after a period of inactivity then the system could actually go to sleep while the screen is off.

I don’t know what the widget is doing, not sure if the above applies to that as well. (It probably does but who knows! Would have to read the source code.)


Thanks @jpetso . I just wish there were more people who could add to the conversation to get other opinions. It’s cool to get a developer response. I really want to donate to KDE once I’ve settled down. It’s the desktop I’ve always wanted.

Press F12 to put your Monitor to sleep. Move your mouse to wake it up again

1 Like

Thanks @jpetso and @Duha . Just tried it. It worked! I made a shortcut key! Will donate! I thought it would work! Just that Linux is wild sometimes due to prior desktop/distro experiences. I am glad it works! I feel happy! Thanks you 2 for helping! :slight_smile:


Turning off FreeSync on the monitor worked for me