UI elements are gigantic

Recently, I decided to switch from GNOME to KDE. However, I forgot that every time I try to use KDE Plasma, this issue occurs, and I’ve never been successful in finding a solution for it.

My UI becomes really large. I’ve attempted to change the DPI, but it only affects certain software like Chromium and Firefox; it doesn’t impact KDE at all. I also tried editing sddm.conf and adding these parameters, but it didn’t make any difference:

ServerArguments=-nolisten tcp -dpi 96


  • OS: Fedora Linux 39 (Workstation Edition) x86_64
  • Kernel: 6.7.3-200.fc39.x86_64
  • Uptime: 12 minutes
  • Packages: 2451 (rpm), 15 (flatpak)
  • Shell: bash 5.2.26
  • Resolution: 1600x900, 1920x1080
  • DE: Plasma 5.27.10
  • WM: KWin
  • Theme: [Plasma], Breeze [GTK2/3]
  • Icons: [Plasma], Breeze [GTK2/3]
  • Terminal: gnome-terminal
  • CPU: AMD Ryzen 5 2600 (12) @ 3.400GHz
  • GPU: NVIDIA GeForce GTX 960
  • Memory: 3685MiB / 15894MiB

Any tips of how to fix this?

What do the sizes in your “Fonts” page in System Settings say?

But also, if it were me, I would not enable anything HiDPI for a display configuration where the pixel-densest screen is 1080p. I figure that’s your monitor, and on anything larger than 14", 1080p is already pretty large even without any kind of scaling. 1600x900 is among the lowest-DPI displays that one can still find in the wild nowadays, even for a small 12" laptop display.

Do you get similar behavior also in a Wayland session?

I tried messing with the font size and dpi scaling but it didn’t had any effects in the scaling other than the font size.

As for the HiDPI I only added that flag to test if it would do anything about the problem, someone pointed out that adding that solved a similar problem but it didn’t help at all with mine.

Yes, I got a similar behavior with the wayland session.

at the top of that settings page is an Adjust All Fonts button which brings up a dialog you can just check the Size option and try scaling the entire UI to your liking.

the font text in your screen shoot is too small to even read, so something is wrong.

i would also turn off the forced dpi setting, or just go back to the defaults and start from there.

Oh that was me, I did the same thing you did there and it only changed the font size, the ui elements stayed gigantic. like I said, Changing the DPI also changed nothing.

Damn, that’s messed up. I don’t have any other good ideas unfortunately.

For the panel, you should be able to reduce its size by going into Edit Mode and adjusting the Panel Height value. Panel elements should resize to the space that they’re given, if the height is shorter then the icons will also occupy less horizontal space. Still, that doesn’t help with the remaining mess.

I uninstalled the NVIDIA drivers and for some reason the scaling went back to normal, however, no hardware acceleration so I can’t really work with that haha, but yeah, I tested an older driver and the scaling is still messed up, probably something related to the Maxwell architecture? I didn’t had problems with a 1060

When switching Desktops like this, I would always also create a new user profile.

I mean, best would be if GNOME and KDE dotfiles could easily be separated…

Hm. Something in the proprietary video driver that gets KDE to force-enable 200% (or more?) scaling despite your settings saying otherwise? Looking at your first screenshot, Firefox and Nvidia settings seem fine so there might indeed be some weird interaction with theming in KDE Frameworks or something.

The only other idea I can think of right now would be to see if this also happens for a new user account on the same system, which would start from an empty set of ~/.config, ~/.cache, ~/.local directories. If it also happens for a new user, at least we could count out configuration errors. [Edit: posted at the same time as the previous comment :stuck_out_tongue: ]

Sorry, I should have clarified better before what I said about this not being the first time. I tested Manjaro KDE and Kubuntu with KDE in the past using the same setup, and they also presented the same problem (ended up forgetting about these distros and installing one with XFCE). Now I’m 100% sure that there’s something wrong with the drivers or this GPU architecture because when the drivers are not installed, the scaling pretty much works perfectly.

i had no issues when running that same GPU on my machine (since then i’ve picked up an AMD card)

i was using the proprietary drivers available with the kunbutu repositories… 535.54.03 i think was the last version i was using.

my dual monitors were both 1920x1080 tho.