Unresponsive black screen after changing BIOS settings

I’m using KDE neon user, and had instances where the GPU (rtx 3060) just stops working and starts spinning really fast. To solve this I reset my (asus) motherboard from ‘performace’ to ‘normal’. I accidentally changed something in the BIOS and ended up having to remove the cmos battery to reset.
After that SDDM didn’t show up and when running startx, Plasma was only using llvmpipe. I tried reinstalling NVIDIA drivers, tried 535 but after installing 545 now the PC won’t boot.

actual problem:
after “Reached target Multi-User System”, the screen freezes and shows a small glitch in the top right corner. I can’t do anything, reboot or get into tty.
I’ve tried removing everything nvidia from recovery, installing nvidia-drivers-535 from recovery.

Did I nuke my system? What should I do?

do you need to re-flash your firmware?

i can’t imagine changing anything in the firmware would affect your linux install, but will all the flailing about you describe it’s hard to know what you’ve done.

try a more methodical approach.

  • does the motherboard post?

  • do the GPU fans spin?

  • can you boot to a live USB?

that kind of thing.

Sorry, I forgot to add that.
The hardware itself works, and Windows works without problems on the other disk

still could be a firmware issue.

check to see that there isn’t a newer firmware available than what you are showing in the settings.

I second above, check for firmware updates, you REALLY should be on latest firmware, ALWAYS!
There is clearly a graphical setting that was changed before and after cmos reset is returned to default.
That seems not working out for you, the question is what setting/settings.

It could be something strange like “re-bar support” (if you have that on your mobo settings and activated that on your nvidia) or even csm support (I recall reading a thread where THAT was the culprit). sigh… Nvidia…

I find it very strange that you get 545 to work and not 525. Could be some kind of call being made to the mobo.
Are the modules installed correctly?

Is SDDM loaded with x11 or wayland?

Debian and software versions, you are most likely very well aware. This should not be connected to that though. Other than it probably would have worked if the repos were up to date with latest softwre, since, well, 545 seems to kinda work for you.

Without knowing what system you use it’s hard to help.
Could we get a inxi -Fazy please? (or some kind of harware/software info like inxi)

Thanks for the tips. After some more tries I ended up being able to reinstall nvidia-drivers using nomodeset. My firmware seems to be up-to date (well the last update was released 10 years ago…).

Pretty basic but steps, but here is what I did for further reference:

  • In the grub select OS menu press e
  • Add nomodeset to the end of the line that starts with “linux /boot/vmlinuz***” ・ this will reset on the next boot
  • After logging in, open Konsole and run sudo ubuntu-drivers listnote that this only works with neon, Kubuntu or Ubuntu Studio
  • If your GPU properly shows run sudo ubuntu-drivers install
  • Reboot and check in “About this system” that your graphics processor is in fact your GPU.

More details for nomodeset here.
More details for ubuntu-drivers here.