Vcpkg is crossing Windows and POSIX paths

I am having many problems trying to build kMyMoney from source on Windows. I am following the procedure in the kMyMoney wiki Build Environment. When I use the cmake command shown, the output includes file not found errors like this–

C:\Users\drfri\kMyMoney>cmake -B Build -S . -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_TOOLCHAIN_FILE=c:/Users/drfri/vcpkg/scripts/buildsystems/vcpkg.cmake -DVCPKG_TARGET_TRIPLET=x64-windows-static -DVCPKG-MANIFEST-ROOT=c:/Users/drfri/kMyMoney
– Running vcpkg install
Failed to load manifest from directory C:\cygdrive\c\Users\drfri\kMyMoney
no such file or directory
note: updating vcpkg by rerunning bootstrap-vcpkg may resolve this failure.
– Running vcpkg install - failed
CMake Error at c:/Users/drfri/vcpkg/scripts/buildsystems/vcpkg.cmake:892 (message):
vcpkg install failed. See logs for more information:
Call Stack (most recent call first):
Build/CMakeFiles/3.23.2/CMakeSystem.cmake:6 (include)
CMakeLists.txt:14 (project)

– Configuring incomplete, errors occurred!
See also “/cygdrive/c/Users/drfri/kMyMoney/Build/CMakeFiles/CMakeOutput.log”.
See also “/cygdrive/c/Users/drfri/kMyMoney/Build/CMakeFiles/CMakeError.log”.

The insertion of “/cygdrive/c/” in that path is preventing me from downloading the package. I have tried all manner of ways of specifying the path to the vcpkg.json file including making a cygdrive subdirectory. Any suggestions would be appreciated. I am also trying to establish an environment on my Kubuntu laptop and download source there.

It’s been a long time since I’ve dabbled with building KMyMoney on windows, so I can’t help much here. However, you mention cygdrive, which implies you are using Cygwin. They do have KMM packaged, but nothing more recent than 5.0,1, which is too old to bother with. I have no idea whether they might be convinced to do a new release - but that won’t help if your goal is building and not just using KMM. Building KMM under cygwin should be possible, and would be more like building under Linux. However, mixing cygwin and naatinve Windows tools (like VS) will not go well - they are too different. I also have no experience at all with vcpkg.

Jack, I am very grateful for the reply. I never thought this was going to be easy and adjusting code for my toolset was probably going to be an issue. I have made substantial progress in the last couple of weeks. I tried this weekend to run cmake/vcpkg for the triple x64-windows-static. It seemed to want to use mingw which is installed but I ran into problems with proxy variables.

Today, I backup up the laptop and restored on my desktop and tried it here. I got a lot farther until my virus software complained about Trojan.win32.sdum.gen in the working directory shown below. I think the package is GMP. I am still disinfecting but when that is finished, I will report this possible infection to which I found by signing into GitHub and following menu choices.

– Downloading;;;;;;; → msys-mingw-w64-i686-libwinpthread-git-…
– Using msys root at C:/Users/drfri/vcpkg/downloads/tools/msys2/9a1ec3f33446b195
– Configuring x64-windows-static-dbg
– Configuring x64-windows-static-rel
CMake Error at scripts/cmake/vcpkg_execute_required_process.cmake:112 (message):Command failed: C:/Users/drfri/vcpkg/downloads/tools/msys2/e6f7ae10db8f00f6/usr/bin/bash.exe --noprofile --norc --debug -c “V=1 CPP=‘compile cl.exe -E’ CC=‘compile cl.exe’ CC_FOR_BUILD=‘compile cl.exe’ CPP_FOR_BUILD=‘compile cl.exe -E’ CXX_FOR_BUILD=‘compile cl.exe’ CXX=‘compile cl.exe’ RC=‘windres-rc rc.exe’ WINDRES=‘windres-rc rc.exe’ AR=‘ar-lib lib.exe’ LD=‘link.exe -verbose’ RANLIB=‘:’ STRIP=‘:’ NM=‘dumpbin.exe -symbols -headers’ DLLTOOL=‘link.exe -verbose -dll’ CCAS=‘:’ AS=‘:’ ./…/src/v6.2.1-0c723d4b6f.clean/configure --build=x86_64-pc-mingw32 "ac_cv_func_memset=yes" "gmp_cv_asm_w32=.word" "CCAS=clang.exe" "ASMFLAGS=-c --target=x86_64-pc-windows-msvc" "–enable-cxx" "–with-pic" "–with-readline=no" "gmp_cv_prog_exeext_for_build=.exe" "ac_cv_prog_ac_ct_STRIP=:" "gl_cv_double_slash_root=yes" "ac_cv_func_memmove=yes" "–disable-silent-rules" "–verbose" "–disable-shared" "–enable-static" "–prefix=/C/Users/drfri/kMyMoney/Build/vcpkg_installed/x64-windows-static" "–bindir=\${prefix}/tools/gmp/bin" "–sbindir=\${prefix}/tools/gmp/sbin" "–libdir=\${prefix}/lib" "–mandir=\${prefix}/share/gmp" "–docdir=\${prefix}/share/gmp" "–datarootdir=\${prefix}/share/gmp"”
Working Directory: C:/Users/drfri/vcpkg/buildtrees/gmp/x64-windows-static-rel
Error code: 77
See logs for more information:
Call Stack (most recent call first):
scripts/cmake/vcpkg_configure_make.cmake:833 (vcpkg_execute_required_process)
ports/gmp/portfile.cmake:85 (vcpkg_configure_make)
scripts/ports.cmake:147 (include)
error: building gmp:x64-windows-static failed with: BUILD_FAILED
Please ensure you’re using the latest port files with git pull and vcpkg update.
Then check for known issues at:

You can submit a new issue at:

@ostroffjh I’m getting nowhere everywhere I turn. I give up.

Let’s go back to the beginning. What is it you are actually trying to do? I certainly know the running in circles feeling - Maybe it isn’t worth the effort, but maybe you just need a fresh perspective. Is your goal to run KMM, to build KMM, or to explicitly build a vcpkg version, or something else?

To build KMM locally so I can modify it’s behavior to make importing easier and to handle fixed income securities and equity options. Without those enhancements, it’s of limited use to me. I started at the wikis/Build-environment page (KDE Discuss is not letting me post links). As I said, most recently I got cmake with vcpkg running and installing but I found a trojan in GMP.

@ostroffjh I am now getting blocked by this board.

Discuss is KDE’s implementation of Discord, and it’s still fairly new here, so I don’t know if there are any rules about posting links, but I wouldn’t be surprised. In the interim, you could switch to the Forums or mailing list (see Support page at
However, if you are just trying to build KMM so you can play with the code, I would suggest a straight build with cmake and ninja from a local git repository (Linux is much easier that Windows for this.) Any packaging system, such as appimage or vcpackage adds an extra layer of xomplexity, often not really needed. It does sometimes take some cycles to get all the dependencies installed, but it does usually work.
In my case, I have a git repo checked out out in a folder “kmymoney,” and parallel to it a build folder “build.” From within build, I do:

CFLAGS=“-O0 -Og -ggdb” CXXFLAGS=$CFLAGS cmake -G Ninja -DCMAKE_BUILD_TYPE=DebugFull
-DCMAKE_various_other_options …/kmymoney

Ninja vs make is a personal preference, as are most of the options. Once you have run that once, you can do “ccmake .” to see the options is is currently using, and regenerate the ninja files. You then run “ninja” (or “make”) to actually do the compile. You also need to specify an INSTALL_PREFIX. Although it is possible to have more than one version installed at once, it is messy and much easier to avoid problems by only having one at a time (i.e., no system or distro package if you install your version. However, see the “” created in the build folder for being able to run directly from the build folder without installing.

Thank you for the encouragement. I will start my adventure in Linux tomorrow. Incidentally, I started out asking questions in the KMM Forum but switched to KDE Discuss because of the header on the forum page talking about it being archived. I will be switching back and see how it goes.