Video chatting doesn't work over Firefox & cannot uninstall stock FF to try a different version

I would like to use Firefox as my browser, but the stock version has issues with video chatting within Firefox and even opening Zoom links. However, they work just fine over Chrome.

The only troubleshooting step my noob self could think of was to uninstall the stock version and try the Discover Flatpak or the version provided directly by Mozilla. However, when I try to uninstall the stock version, I get the error requesting that I submit a bug. Any troubleshooting ideas?

OS: KDE Neon 6.0
Kernel: 6.5.0-26-generic
DE: PLasma 6.0.3
GPU: NVIDIA GeForce GTX 1060 6GB
GPU Driver: nvidia-driver-535

You don’t have to remove the existing Firefox to use the flatpak, or the binary download from Mozilla. However, it is hard to tell from the Application Menu which one is which until you edit one of the entries or something.

neon sources Firefox debs from Mozilla’s official PPA.

I have no issues opening zoom links myself, but I have no idea if this is from something I did some time in the past. I get this directly from Zoom as a deb, not the flatpak from Discover.

Are you using xorg, or a Wayland session? Have you tried both?

1 Like

This error message happened because Neon deliberately hides apps from the repos in Discover. If you were not aware of this, see this FAQ entry.

…Hence Discover can’t find Firefox when you ask to see it. Kind of an unfortunate coincidence, but it’s basically a “behaves as intended” situation from Neon’s perspective.

Anyway, indeed you don’t need to uninstall the distro-packaged Firefox to install the Flatpak version.

1 Like

I’ve only tried Wayland, not X11.

However, I just installed the Flatpak version. I wont have a video conference for a week, so I’ll wait until then, and report if the Flatpak version solved the issue :slight_smile:

The Flatpak Firefox worked for video chat yesterday, so it’s all good!