Virtual desktop on primary screen only

Im running EndeavourOS with latest Plasma 6 on 2 Monitors.

How do I make the virtual desktop only work on my primary Monitor?

I have 2 Monitors. One LG (primary) with DisplayPort, other Iiyami with HDMI.
There are 4 virtual monitors set up.
The plasma panel is on the primary LG monitor.
As soon as I select virtual desktop, from 1 to 2 or 3/4, the secondary monitor also switches the virtual desktop. I would like to turn it off. This is really annoying when I have the console open on the second monitor and change the workspace on my primary screen.

What settings do I need to make so that the virtual desktop only appears on my primary desktop (LG)?

1 Like

This is not possible to do currently. It’s a somewhat often requested feature, and might get implemented in a future release.


Thank you very much for your kind answer. That explains everything… Have a nice day!

Haven’t tried it, but you could test if using different Activities would work in your case, as far as I know Virtual Desktops in different Activities are independent from each other.

1 Like

As a workaround you can pin windows to stay on all desktops. You can add the button to the titlebar in the system settings > window decorations page

1 Like

That workaround is great! Thank you very much for your suggestion.

Found this script: GitHub - wsdfhjxc/kwin-scripts: Some scripts for KWin

When the script is enabled, all windows placed on monitors other than the primary, are automatically set to be shown on all virtual desktops. This can be considered a hack, but from the user’s perspective, this effectively results in having multiple switchable virtual desktops on the primary monitor, and fixed non-switchable virtual desktops on other monitors. That’s how GNOME Shell handles workspaces by default, and the script mimics that.

It fails to install on Plasma 6, though.

Potentially more up-to-date script I can’t figure out how to install: GitHub - hnjae/kwin-scripts: Some scripts for KWin