Volume buttons are detected, but still don't work

Hey everyone, new here! Just installed Kubuntu onto my laptop as a daily driver. Liking everything a lot so far, but there’s just one thing; it seems like my volume buttons don’t work. The mute, vol-up, and vol-down buttons don’t change the volume at all. What’s weird, however, is that when I tried adding them as a custom shortcut (assuming they just hadn’t been detected automatically, like on my previous Mint laptop), I got a message saying the volume-up button, in this instance, was already in use. Then, trying elsewhere, when I hit the button, it registered correctly as the volume-up button. What might be going on here? Please let me know if there’s any more information you need, and ideally where I can find it! Still working out all the kinks to my new system.

Buttons on your keyboard? Mine used to work then stopped working and now work again.

If you mean the keyboard volume butttons can you tell me your kernel version and keyboard name?

I do mean the keyboard volume buttons - the ones with the little volume icons printed on them - sorry for the confusion. Here’s my system info:

Operating System: Kubuntu 22.04
KDE Plasma Version: 5.24.7
KDE Frameworks Version: 5.92.0
Qt Version: 5.15.3
Kernel Version: 6.2.0-26-generic (64-bit)
Graphics Platform: X11
Processors: 12 × 13th Gen Intel® Core™ i5-1335U
Memory: 11.4 GiB of RAM
Graphics Processor: Mesa Intel® Graphics

As for my keyboard name, I’m not sure what you mean. It’s the keyboard built into my HP laptop, if that helps.

EDIT: Woah, it’s working! I genuinely don’t know what I did. I tried restarting already and that didn’t work, so I guess it just fixed itself? In any case, thank you for the willingness to help, @Duha!

1 Like

Glad it works for you. Please mark your thread solved

what does

xev | grep key

give you when you use the buttons?

Sorry! Didn’t see the Solution button before. I just selected the reply where I said it was suddenly working, is that alright?

1 Like

Yes that is correct.

Did you by any chance add an Audio Volume widget somewhere, then delete it, and not restart plasma or the system right afterwards?

Hadn’t added any widgets to speak, if memory serves correctly. Though I can’t say with 100% certainty. More like 90%.

For me, adding an Audio Volume widget allowed me to change volume while the widget was present. Ultimately, unchecking/checking Play audio feedback for changes to: Audio volume and Show visual feedback for changes to: Audio volume in Settings -> Audio -> Configure volume controls fixed the issue for me without restarting

The problem occurred when my panel froze and I restarted it with plasmashell --replace and then I noticed my keyboard volume buttons didn’t do anything: pressing volume up didnt show any OSD nor did it change my default audio device’s volume, but it did work on individual applications like mpv. So I did systemctl --user restart pipewire.service, tried changing default audio output device with no success in changing main audio device volume by keyboard.

I found this thread and tried adding an audio widget to my panel. This allowed me to change volumes on my default audio device as long as the widget was present. As soon as the widget was removed, the buttons stopped working. I didn’t want an extra widget in my panel so I needed a more permanent fix.

Unchecking and then checking the following options in Settings -> Audio -> Configure volume controls seemed to do something:

  • Play audio feedback for changes to: Audio volume
  • Show visual feedback for changes to: Audio volume
    I think it crashed my panel but I regained the ability to use my keyboard volume buttons for changing volume on the default audio output device.

Operating System: Fedora Linux 38 (Fedora Kinoite)
KDE Plasma Version: 5.27.6
KDE Frameworks Version: 5.108.0
Qt Version: 5.15.10
Kernel Version: 6.4.4-200.fc38.x86_64 (64-bit)
Graphics Platform: Wayland
Processors: 16 × AMD Ryzen 7 3700X 8-Core Processor
Memory: 31.3 GiB of RAM
Graphics Processor: NVIDIA GeForce GTX 1070/PCIe/SSE2