Volume control?

I can’t find a volume control slider in Kdenlive. In the emedded video player, there are buttons for play, forward and rewind, but nothing for volume. Every other video player has a volume slider. Why is it missing here?

There are tutorial videos on how to change volume within the clips (via gain, keyframes and whatnot). But I don’t want to change the clips. I only want to adjust the output volume in the player.

Click on the ‘hamburger’ menu in the Project Monitor toolbar (it’s the three stacked lines). There you have the volume control. Alternatively, make sure the Audio Mixer widget is on (Menu > View > Audio Mixer). There you have the Master track and a volume slider.

1 Like

That’s a good tip, I didn’t know it, but had never needed it before, but good to know.

Thanks. I don’t know why I overlooked the slider in the sandwich menu. It does what I want.

The “Audio Mixer” widget (panel) doesn’t seem to have any effect though. No matter which of the 3 sliders I move, the output volume remains the same. It must serve some obscure other purpose then.

That is weird. It works for me (Pop1_OS 22.04 with several appimage versions of Kdenlive and 23.04.1 installed via kdenlive-stable ppa) just like it is supposed to …

How is the mixer even supposed to work? While the slider in the sandwich menu scales from “0%” to “100%” as expected, the mixer’s units are “dB” which means you can’t turn the sound completely off by dragging a slider to the bottom. What confuses me even more is that the numbers on the bottom contradict the numbers to the left of each slider:


For the screenshot, I left the left slider in the default position which is around -16 according to the scale beside it. But the number input field at the bottom contains the value 0,00dB. I moved the second slider to the top, that’s 0 dB according to the scale, but the number input field went to 24,00 dB. I moved the master slider to the bottom, which looks like it should be around -60, but the number input field says -24,23dB.

Looking closer at the scale, I also notice that the “-50” mark isn’t in the right place. Even though the scale is logarithmic, the -40 and -50 marks should be further apart.

Meanwhile I found out that the clips in the “Project Bin” tab can be drag&dropped into the bottom left panel, where they are combined. The combined video appears in the top right player. While both players have their own sandwich menu with a volume slider, only the right player is influenced by the mixer.

Anyway, the mixer doesn’t exactly do the same thing as the sandwich slider. When I move the master slider in the mixer, the sandwich slider keeps its position, and vice versa. I assume that the mixer A1 and A2 values are applied first, then the master value, and finally the sandwich slider. While the sandwich slider certainly doesn’t propagate into an exported file, the mixer setting may or may not affect the volume in the output file. As this isn’t documented, the only way to find out might be to try it out. Still confused about the scale.

Well, the audio mixer widget is basically a beefed up volume effect applied to audio tracks A1 and A1 and a volume effect applied to Master. You may just switch off the mixer widget and use the screen space for something else and work with volume effects on A1, A2 and Master (which you have to add to the tracks and Master, though).
The volume control for the Clip Monitor and the Project Monitor is only for the playback of the clip selected in the Project Bin or the project timeline. The audio mixer slider settings affect the playback volume, but the playback volume slider does not affect the audio volume of the rendered video.

I will look into the documentation of this in more detail. Thanks for the hint.