Wayland: laggy cursor in game menus with VRR enabled

Hi guys I found an issue when using Wayland with VRR enabled, my mouse is laggy in fullscreen game menus (via wine/proton) doesn’t happen on native games like dota2…

my screen is 144hz , games are 144hz but mouse is like 15fps… fixed when I either disable VRR or switch back to x11

Im on Arch, 5.3 kernel, KDE 5.27.6 with AMD 6700, tried changing compositor settings which didn’t help also tried lutrus wine 7, proton 7/8 and proton GE etc.

I guess this could be the issue? Handling cursor updates with VRR (#85) · Issues · Plasma / KWin · GitLab hoping a fix is in the works also im torn between going back to x11 or keeping VRR disabled

This is almost certainly With vrr and atomic modesetting, some cursor plane updates are dropped (#2186) · Issues · drm / amd · GitLab

As a workaround you can put


into /etc/environment. Assuming it’s the same issue as the one I linked, the cursor should stay smooth after a reboot


Thanks workaround has fixed the issue for now will keel an eye on the AMD issue for updates