What is kded5 and why is it trying to mount an unused partition?

“plasma_session” kicks off “kded5” and that process mounts an alternate ROOT partition:

/dev/sdc2 58G 14G 44G 24% /run/media/bkorb/ROOT1

I didn’t ask for it, but I got it anyway. Why? Oh, and how do I stop it (other than dismissing the root password request)?

Hello @bkorb!

kded5 is a KDE daemon, it’s normal that it’s running on your system.

As for why it mounts root there I don’t know.
What were you doing when the password promt appeared?
Using dolphin for example?
Or maybe you clicked something that tried yo mount it?

It’s a new “feature” in booting up with the startup set to not reviving anything. :slight_smile:
So, I have no clue how I started it and, consequently, no clue how to stop it, either. :frowning:
(For clarity, there’s no entry for it in /etc/fstab either.)

$ find * -type f -print0|xargs -0 grep ROOT1
Binary file google-chrome/Default/IndexedDB/https_discuss.kde.org_0.indexeddb.leveldb/000003.log matches
Binary file google-chrome/Default/Service Worker/CacheStorage/be211c829d705234352e056d4966ee3fd94036d8/0311369c-008d-4c36-bf66-7f97616dad26/fcf6bdc93536e976_0 matches
Binary file google-chrome/Default/Service Worker/CacheStorage/be211c829d705234352e056d4966ee3fd94036d8/0311369c-008d-4c36-bf66-7f97616dad26/413b3f5b20b3e7b9_0 matches
Binary file google-chrome/Default/Service Worker/CacheStorage/be211c829d705234352e056d4966ee3fd94036d8/0311369c-008d-4c36-bf66-7f97616dad26/ff08f3498b8148bc_0 matches
Binary file google-chrome/Default/Service Worker/CacheStorage/be211c829d705234352e056d4966ee3fd94036d8/0311369c-008d-4c36-bf66-7f97616dad26/9664a969c3285ce3_0 matches
Binary file google-chrome/Default/Service Worker/CacheStorage/be211c829d705234352e056d4966ee3fd94036d8/0311369c-008d-4c36-bf66-7f97616dad26/088bc5325c5d79b6_0 matches

Perhaps auto mounting was somehow enabled in Settings → Removable Storage → Removable Devices and you have to uncheck that option.

It seems like you or your distro turned on automount, either for all disks or just that one. You can turn it off–either for all disks, or just that one.

Perhaps my understanding is out-of-date. I thought all distros turned on automount and that would mount everything mentioned in /etc/fstab. The “ROOT1” partition is not mentioned, it is not a removable device, and it is mounted under /run/media/user/ROOT1. It is very weird.

OK. I went to:
SYSTEM Settings → Removable Storage → Removable Devices
and, lo, there were the partitions not mentioned in /etc/fstab under “Attached Devices” – despite the fact I was in a “Removable” section. OK. so the BOOT and ROOT1 partitions are marked to be automounted “on login” and “on attach”. Dunno what happened to cause that, but there’s not much I can do about it. Everything is greyed out and not modifiable, except the column headers. So, I’ve now disabled all automounting of “removable” devices. It works, but it all seems quite bizarre.



Which Distri are you using?

What is the output of:

 for file in /sys/class/block/*/removable ; do echo $file :$(cat $file); done
$ cat /etc/*elease*;echo;for file in /sys/class/block/*/removable ; do echo $file :$(cat $file); done
NAME="openSUSE Leap"
ID_LIKE="suse opensuse"
PRETTY_NAME="openSUSE Leap 15.4"

/sys/class/block/md0/removable :0
/sys/class/block/sda/removable :0
/sys/class/block/sdb/removable :0
/sys/class/block/sdc/removable :0
/sys/class/block/sdd/removable :1
/sys/class/block/sr0/removable :1