Why can't I put date in front of time on KDE panel?

In settings of clock widget (in KDE panel) I can’t put date in front of time to compose view like Oct 28, Sat, 18:14

Some people say they have additional drop down menu to select where date could be put. But I don’t have it.


I use the latest KDE Plasma 5.27.8 from official repo.


more details here, rtfm :slight_smile:

Format String is for date only, not time.

If I put something like MMM d ddd hh:mm as a format string,
then output on panel will be Oct 28 Sat hh:mm

1 Like

the .qml does not parse hh:mm in the date field and there is no toggle for switching things in mine either (don’t think that’s a thing in plasma 5)

you might be able to cut the block of .qml code for parsing the date and paste it above the block that deals with the time but i have no idea if that would break things or not.

run kpackagetool5 --install /usr/share/plasma/plasmoids/org.kde.plasma.digitalclock/

and then you will have a copy of the .qml in your .local to play with… if you break it just delete the directory and start over

You can try out Event Calendar as an alternative clock/calender, this provides you with a freely configurable date/time format string (in the “General” section of the settings). It works very well for my needs - I want to have just the date displayed, and time only by hovering with mouse.

Replace your clock with Better Inline Clock. you’ll have to go to add widgets and then download it, but it’s worth it.