Why do Adblockers break KDE Discuss?

This makes very little sense. I thought for weeks that it was down, and it was just Ublock origin?

What is the cause here?

1 Like

Ive been using adblockers just fine, I even have a fairly strict firefox setup with no issues so im not thinking its adblockers and you may be jumping to conclusions without actually figuring out what the problem actually is.


Using Ublock with Vivaldi - both actively blocking - with no issues, on this site or any other Discuss site, for that matter.

Can you be more specific than “break KDS Discuss”?


Just to chime in from a different setup, I’ve used KDE Discuss pretty regularly in both Firefox w/Strict Tracking Protection enabled plus uBlock Origin installed, and in Brave with “Shields Up”, and haven’t had any issues with viewing the site, staying signed in, etc.

If removing uBlock Origin solved the issue for you, maybe check to make sure that was the legit version of uBlock Origin, and that it installed correctly? (I can imagine that, if the extension or its rules were corrupted somehow, something with the broad scope of uBlock Origin could really cause some havoc)


The delusion is strong with the OP. I have uBluck Origin and AdBlock Plus with Vivaldi’s and not one issue.

1 Like

I’ve have uBlock installed on latest firefox and the site works as I would expect.

It might be worth while clearing your cache or checking other extensions that you might have installed. Try another browser with uBlock installed.

1 Like

I mean it really depends on the filter lists being used. Your screenshot @RobLW might not be representative at all. However from the overall quota (38%) one might assume you are using a rather strict setup.

1 Like

Sorry @kdeIsGreat, not sure what your point is exactly? My screenshot isn’t trying to represent anything, it merely provides the OP evidence that uBlock can be used in conjunction with the forum perfectly fine and is likely something they have setup or another extension causing them problems. The OP provides no details of their setup to “represent” or compare to.
Perhaps trying to help the OP directly is more productive.


The point @RobLW is that “uBlock can be used in conjunction with the forum” does not mean anything (and is no evidence) if you don’t talk about the filters being used (domains, as well as cosmetic rules which uBlock provides). The compatibility therefore highly depends on its configuration, which specifically yours seems to work with. However, it clearly sounds like a local config problem anyway.
Perhaps it is, I am not the one digressing into extraneous discussions.

1 Like

I enabled all filters for uBlock Origin and I don’t experience any issue.


weird. So a little more details:

I use Firefox+Arkenfox and Mull on Android. KDE Discuss worked totally fine, until some moment when it stayed in the “moving dots” loading screen.

Then I tried it with LineageOSses Jelly browser and it suddenly worked.

Suddenly now it works again? Maybe it was a specific VPN server that was blocked?

Meanwhile fedora discuss for example worked normally.

Using Firefox with uBlock Origin - and no issues here, sorry. I hadn’t noticed any ads TBH and it seems to make no difference if I disable it.

hanging at the three moving dots, sounds like something I experience from time to time with fenec.

Quick fix for me. I quit the app (from fenec’s menu), clear the cache, start fenec, go to discuss and then it loads the site again and I’m able to log back in.

No issues here with uBlock Origin.


Yea you were, and yea you are.

weird, it works for me again, and I have the same filters I guess. So this is solved, even though still pretty weird

1 Like

I wonder if it might have something to do with the ongoing cat-and-mouse-game between ad blockers and YouTube. Lots of updates recently, and maybe discuss ran afoul of one of them before it got reverted. Just a random guess.

I have all but 2 of the filter lists on for ublock origin along with a firefox config that fairly strict and breaks reddit, twitch, and youtube partially and discuss hasnt had a hiccup for me :man_shrugging:

1 Like

Yes me neither, with the same configs. Maybe some DDOS protection thing? But I guess it is solved