Window can not Maximized

Since Montane, kdenlive is no longer usable, the window can no longer be maximized, I can drag wherever I want, it remains stubborn, why is such an error not noticed and fixed??

You can’t work like that if half of it is missing

It has not been fixed because either

  1. It is not a common bug and nobody has had this happen to them except you
  2. it is not a bug at all and you have accidentally triggered Plasma’s feature that allows you to force a window to have a fixed size

If it is (1), you have to send a bug report to

describing precisely what the problem is so devs can investigate. Remember to be polite!


before you do that, check it is not (2).

  1. Right click on the window’s title bar and choose More actions… (sorry: I don’t speak German so I have to guide you in English) from the pop up menu.

  2. From the submenu, choose Configure Special Window Settings and check that none of the properties are related to the size of the window (see image below).

Note that it could be expressed differently.

  1. If there is a size-related property, remove it by clicking on the trash can icon on the right and click the Apply button.

You should be able to resize the window now, but if you still can’t, repeat same steps detailed above, but, in (2), instead of choosing Configure Special Window Settings, choose Configure Special Application Settings, and repeat step (3) as above.

I didn’t accidentally trigger, install and start anything and there was the dilemma.
It’s exactly the same error under Linux Mint - I have to pull everything by hand and none of the functions you described are activated or anything else. The funny thing is that the error didn’t exist before and now they want to tell me it’s not a bug???
It’s probably a bug, a programming error that was included in one of the kdenlive updates.
I also reported the bug to the responsible authority today.
And why are you showing me a Firefox settings window? We’re talking about KDENLIVE here.

There are no other window settings

And on the Laptop the window automatically switches to the desktop, which wasn’t strange. But no, it’s not a bug. Stop telling me fairy tales and just admit that something was screwed up and it’s fine.

He was using a Firefox window as an example. Probably because he doesn’t have Kdenlive installed.

What is Montane? And which version are you using? What is your screen resolution? OS, I am guessing, is Linux Mint, right? Which version? Any updates lately?

BTW, Kdenlive uses Qt5 for all the windowing etc. The devs would be stupid programming stuff like that themselves. So, if you cannot maximize, minimize, or change window size and position, usually it has to do with the window managing engine.

I have Linux Mint on a notebook with 1920x1080 and Kdenlive 23.08.2 works just fine: I can move it round and minimize, maxime to my heart’s content.

Try the appimage, and stay away from flatpak installs as there are known issues with them.

I have version 23.08.3 and Linux Mint yes.
No flatpack installation? Well then tell me an install version that works via sudo.
It’s exactly the same with the image that I can’t maximize anything.
And as already written before version 23.08.3 or 2, this error was NOT.
I have to set the bar at the bottom to disappear so I can see the rest.
It’s just messed up with some update and NO ONE wants to admit it.

Again, no proof it is Kdenlive alone. Perhaps a system update messed something else up. Just updated to 23.08.3 myself and no issues of that kind whatsoever.

Add ppa:kdenlive/kdenlive-stable to your package manager, or follow these instructions.

What is that supposed to do?
Nothing happens and the window resolution/display is still incorrect.

This is the name of the ppa you need to add to your Linux Mint software manager (see this article for instructions) so that you can install Kdenlive as a .deb package. The flatpak version of Kdenlive may have issues.

You asked for something that works with sudo, so I assumed you are familiar with that. But here it is directly:

sudo add-apt-repository ppa:kdenlive/kdenlive-stable
sudo apt update
sudo apt install kdenlive

This is also available via the link I provided in my previous post.

It’s the same effect if I install it with sudo. EXACTLY the same error and support still hasn’t gotten around to giving any feedback.
It’s just sad how some developers work these days.

And there is no deb package, at least for those on the site

I am sorry it didn’t solve your problem. As I said before, this behavior seems to be limited to your environment, as I can do all the things on my Pop!_OS as well as Linux Mint systems that you cannot regardless of the installation method including the appimage. Please look in other forums (e.g. Linux Mint) for possible solutions.

Well, the Kdenlive dev team is small as it is, and they work on this great piece of free software after hours and in their free time. I am sure you understand that working for money to feed your family is more important than that, let alone waiting for bug reports. You can support and motivate them to spend more time on Kdenlive by donating here.

I went to see the bug report you logged on November 12th. The description of the problem is rather thin but it may work for the devs to figure out what the issue may be. Next time, please provide more details about your environment. I also changed the category to User Interface.

I would like to ask you to be more patient. You logged the bug two days ago, so it is a bit unbecoming to complain about not having received a fix. If this issue has been around for as long as you say why haven’t you logged it earlier?

Thanks for your understanding …


Well, what does it look like here???
Let’s ask another question, under Windoof there are so-called config files as well as in games where you can change the display size. Is that also the case with kdenlive?
If yes, please provide EXACT location.

I don’t use kdenlive but it’s weird that whenever I google this issue I find a lot of “View - > Dock Are Orientation” solutions.

This depends on how you installed Kdenlive or whether you are using the appimage.

Search for the *rc files listed here (Kdenlive on Linux uses the same filenames but stores them in different folders).

I am repeating myself, but I don’t think the issue you are experiencing has anything to do with Kdenlive. Except, perhaps, for one thing: What is the resolution of the screen you are running Kdenlive on?

1360 768, But it looks like I solved the problem myself.

That’s great! Care to share your solution with the community in case someone else experiences the same?

So sad … and really disappointing

1 Like

Well, it’s your own fault, treat the forum users sensibly, don’t make them look stupid and also offer something and then it works, but in this forum you just want to keep to yourself. Just do nothing, that’s how it works no comm, not even a hint and as long as you don’t understand that, this will simply remain a toxic place that you can safely avoid.

Everyone here is a volunteer. None of us are paid to help. You started this thread with a chip on your shoulder and ended it the same way. At least it didn’t fall off and hurt your foot.

1 Like