Window moved by window rule also switches the virtual desktop

Hello there,

I am currently using ffplay (utility from ffmpeg) to play media files. I have a simple playlist format that can be played by a shell script.
Now, when I’m doing things while listening to music, I don’t want to let the new tracks (=new windows) disturb my workflow. So I created a window rule to move all “ffplay” windows to the first virtual desktop, so I can do my work on the second virtual desktop.
In Plasma 5, everything worked well. But now, with Plasma 6, the virtual desktop view switches too, so with a new track Plasma switches to the first virtual desktop where my script runs. Switching back every time a new track starts is annoying.
Can we disable this behavior or is this a bug?
I already tried setting System Settings > Window Management > Window Behavior > Advanced > Virtual Desktop Behavior to “Do Nothing”, it didn’t change anything.

Looking forwards,
Samuel Fiedler

Could you set the “Focus stealing prevention” setting for the window rule be set to something above “None” to prevent it taking focus?

The level of “Extreme” prevents it from stealing focus entirely, but you could test levels lower than that as well.

1 Like

Even “high” didn’t help. I had to set it to “extreme” to get it working…

EDIT: “high” does not work if you have nothing on your virtual desktop. If you have any window open there, then “high” works too.