Windows sticking together

I have noticed a new behaviour since upgrading to Debian 12 (and Plasma 5.27.5).

My windows keep getting stuck together in the middle so I can’t resize them independently.

This is extremely problematic as I like to leave a gap in the middle so I can see the windows behind.

This seems to activate every time I drag a window to left or right edge and I can’t find any way to turn this off.

click on the background anywhere and type

behavior

under the “movement” tab you should find snap settings for edges and other windows.

@skyfishgoo - I don’t think that’s what @xylon is talking about, but OTOH I can’t figure out what “Behavior” → “Movement” is about at all.

I think he’s talking about the new titling feature where if you have half-tiled windows on both left and right (or both up and down), then resizing one of the shared borders, resizes the other so the windows stay attached to each other (“magnetic borders”, I think I’ve heard it refer to - I think it mimic some new feature of MS-Windows).

This is Bug 438788, and there is some discussion there about the same issue @xylon is having, and they mention that you can disable this behavior in System Settings → Workspace Behavior → Screen Edges and unchecking “Tile”. I’ve tested, and it kind of works for new half-tiles, but if you already have a half-and-half tiling setup, disabling “Tile” does not cause the existing pairs to detach.

the snap zone default is 10px on my kubuntu and whenever a window edge gets within that distance of another window edge or the edge of the screen (or even the center) it will snap to it.

dunno if this is what mac does but it handy for making your own version of a tiled desktop nice and neat.

the OP mentioned wanting to leave a gap between windows and the snap was preventing that… just make the snap less and it won’t “grab” the window as much… i can position windows normally as long as i don’t get within 10px of another edge.

Yea - I see it. I’m using wobbly windows so its harder to see subtle movement like that with the window flapping all over :smiley: . But from “I can’t resize them independently” I think @xylon is talking about the tiling feature.

Yes guss has it right. I don’t mind the snapping I mind this new feature where they get stuck together and cannot be unstuck.

I will give instructions to reproduce.

With empty desktop, open console and drag to left screen edge. For me this tiles to 25% screen width.

Now open a firefox and drag it to right screen edge. I expect it to go to 50% width but instead it expands all the way over to meet the terminal.

Now try to resize from the middle. They stick together and resizing one resizes them both.

I like the way window tiling worked on Debian 11 KDE. This new behaviour breaks my workflow. Only workaround seems to be to not use tiling at-all.

Builtin tiling is a new feature in KDE 5.27 and it is still not fully baked.

Its main feature is an integrated tiling configuration that you can access by pressing [META]+[T] - there you can create and remove tiles and set the sizes of tiles. Then if you drag a window while holding [SHIFT] - Plasma will offer you to put it into the tiling box.

That part works more or less OK, though it is sorely missing more keyboard shortcuts: a tiling window manager’s whole point is to reduce the amount of mousing needed for window management, but with the current setup you can’t use the keyboard to tile windows - they have to be “specially dragged” with the mouse.

Plasma has “quick tiling” keyboard shortcuts that operate the same tiling functions as you get with dragging windows to screen edges (and a bit more - you can tile to the bottom half of the screen, that you can’t do by dragging), but these do not interact with the new tiling mode - but its worse than that:

The problem is that during the introduction of the tiling manager, we also got changes to the quick tiling and edge tiling functionality - which I feel was supposed to be part of the same work, but they don’t work well together at all: when you quick tile, or edge tile, two or more windows side by side, their borders are now (in 5.27) magnetic so resizing the shared border resizes all other tiled windows by dragging their attached borders as well - kind of like what you want a tiling window manager to do - but this tile setup does not correspond with the tiling setup you access using [META]+[T]! It forms a different tiling setup than the one you see in the tiling overlay. This is what you turn off when you uncheck “Tile” in the “Screen edges” configuration - with that unchecked you no longer have magnetic borders, but you also don’t have “drag to edge to tile” function. The quick tiling keyboard shortcuts still work tough.

I think you’re not talking about that new “tling” thing but the default half/half or quarter tiling. If you mean the new “tiling”, it needs to be enabled in system settings first and you activate it by meta+t.
This is default ( where windows stick together):

This is the new “tiling” ( in which case you can drag them separately):


How do you enable the new tiling in your system settings? Or more to the point - how to disable this? The “Screen Edges” → “Tile” checkbox does not: after you uncheck it, [META]+[T] still starts the tiling overview, and moving windows with [SHIFT] held still tiles them.

I don’t feel like the new tiling framework and UI are distinctly different than the new quick/edge tiling behaviour that was introduced in 5.27: magnetic borders (what the original ticket calls “Windows fancy zones”) that persisting their sizes across sessions - these were all introduced in the same 438788 bug report.

I looked at the source code in that change and there’s no configuration options there - the magnetic borders can only be turned off by turning off edge tiling - which is likely not what @xylon wants - and the new tiling, to the best of my knowledge, cannot be turned off at all.

It is right here, and the only thing that you find in System Settings if you search for “tile”:

If you disable this, you lose the behavior of “half-tile or quarter-tile by pushing the window to an edge or corner”. You also lose the magnetic border behavior of 5.27, even though the “quick tile” keyboard shortcuts still work, so you can still do a half-and-half quick tile - exactly like edge tiling does.

To the best of my understanding, this is what @xylon’s post is about, it is not about the new tiling editor overlay or its [SHIFT] window dragging behavior, and I’m sorry that I mentioned it at all.

I did find the “Tiling Editor” desktop effect, eventually (*). Disabling it only disables the overlay that you get by pressing [META]+[T] - it doesn’t actually disable the tiling behavior you get with [SHIFT] window dragging, which I believe is on purpose.

*) @dzon: please, please, pretty please - don’t post screenshots of German translated Plasma screens as an example to other people how things should look - I see you do that a lot, but most of us don’t read German and the text on our screens look nothing alike, so it is mostly confusing and not that helpful. For example: your screen’s text says “Bewerker voor tegels plaatsen”, while in English it says “Tiling Editor” - there’s no way I could have read your screen and find what it was in English.

1 Like

I disagree with my posting screenshots to help some people, regardless what language they’re in. It helped people before. Secondly, they’re Dutch. I added a german translation in my post because I thought, for whatever reason, you are German. So, my intention was far from trying to confuse. Furthermore, I see a lot ( as in a LOT) of “do this do that” posts that are, at least imho, far more confusing and besides the point than some screenshots trying to help people with a visual. When I’m in the subway in Tokio I look at the maps in the cars although I can’t read Japanese. At least it gives me some idea. But fine, I’ll stop any visual whatsoever from now on. I sure hope that non-natively speaking KDE users do have a good understanding of English cause, well, everybody knows that 99% of kde users are anglo of course. Glad you found that setting btw.

  1. I apologize for not identifying your language correctly.
  2. Your point is made about offering visual aid, but I do contend that unless the screenshot’s point is mostly some non-verbal visualization, it can be very confusing, and it need not be (see point 4).
  3. While I believe it is true that most KDE users are not native English speakers (if only because most people are not native English speakers), even less of them are Dutch speakers. English is the lingua franca (if you’ll excuse my Latin) of discussions on KDE discuss specificaly, and more generally in technology and the word et-al. If you want to communicate clearly, without targeting a very specific known user base who share a common language - using English will give you massively better results than using any other language. I’m not a native English speaker, and when I write for my cohort - on specific Facebook groups, for example - I do so in Hebrew, but on international public forums, I post exclusively in English even if I know there are Hebrew speakers around - it is the polite thing to do.
  4. It is super easy to show a screenshot in English (which, if you’d have tried, could also have prevented you missing the word “tile” in “Screen Edges”), by running the application with the LANGUAGE=en environment variable. This is how I found out that if you search “tile” in System Setting when running with a Dutch locale, you will still be pointed at “Schermranden” where “Tegel” is clearly visible.

Exactly. Non-verbal aid as in “image, layout, icons,pictures…”.
Yeah, well, like I said. What’s the point to have Dutch, German, Urdu, French, Portugese…etc sub sections on forums right.
But hey, especially for the “clear communicaters”… (Btw, setting that variable only partially changes language.)

This post describes exactly the issue I’m having, but it doesn’t appear there was a clear resolution. Were you able to do anything to change the behavior of the snapping windows other than just unchecking the “Tile: Windows dragged to left or right edge” button?

I haven’t used KDE since the early 2000’s and I decided to switch over from Gnome recently, and I wasn’t sure if this was something that was working as intended, a bug, or something that can be easily changed.

This was a recent change in the behaviour of “quick window tiling” that came with the new tiling architecture - that is still not fully baked.

Currently there’s no way to disable this behaviour except to disable quick tiling as described in this thread.

There are some bug reports that mention this issue but the discussion around it is often confused with other wanted and unwanted behaviours. Maybe a new bug report should be created for a new feature for users to disable “magnetic borders” for quick tiled windows.

I reported a bug for this UX-regression: 480223 – Magnetic borders are forced for quicked tiled windows