WireGuard, using "Connections"

I’ve got a WG connection setup. Easy as pie on my Unifi.

Phone’s connected.

But I’m having trouble setting up the VPN using Plasma’s Settings GUI.

Here’s what I have:
Config file for WG, as provided by unifi:

PrivateKey = +Gx[PK removed]
Address =

PublicKey = Csn[ PK removed]
AllowedIPs =,,
Endpoint = [public IP removed]:51820

And here is the connection:
the private key from the config file is loaded here.

Here is the peer:

Here is the IP address I manually set:

When I turn on the connection I have no network access.
Can’t ping google,, or the router

What am I doing wrong?

I don’t see anything wrong. At least aside from the fact you’re not using a preshared key (PSK). :stuck_out_tongue:

Are you sure the DNS should be pointing to, though?

And usually a persistent keepalive of 25 is common practice for you to stay connected (it might be set from the server side though).


You didn’t actually mention the issue you’re facing.

Regardless, you can try deleting the connection from the Plasma widget and see if you can import the VPN file manually with nmcli:

nmcli connection import type wireguard file <yourfilehere>

If it works, that would confirm whether this is a problem with the Plasma VPN stuff or with the file itself.

Oh, my bad. Problem is there is no network connection.

And, yes, I should use a PSK.

Before that, I want to get this thing connected.

That aslso did not work.

Here’s the config from my try:

And here is the config using nmcli:

Still no network access. Not sure what I am doing wrong. I have another unifi device on a different network I can test with. I just find it odd that i can connect with my phone, but not my laptop.

Welp. Near 15 years in IT and I still don’t troubleshoot at step 1…

I forgot to click apply when i added the client to my VPN client list in the router…

Problem solved.

I know this is a solved issue but for future google searchers such as myself - make sure you change the default name of your wireguard VPN connection. it will not accept spaces and will fail to save your profile. At least under 5.27. I intend to test under kde plasma 6 and file some bugs