Workarounds/fixes suggestions for kwin repeated crashes


I am running Kubuntu 22.04 with the following software setup:
KWin version: 5.24.7
Qt Version: 5.15.3
Qt compile version: 5.15.3
XCB compile version: 1.14

Full output of qdbus org.kde.KWin /KWin supportInformation:

A few days ago I started to get repeated kwin crashes, typically I get a crash at login, the window decorators disappear and sometimes the system remains “stable” in this state, but other times something triggers further repeated crashes (observed them based on crash notifications in the tray). Often the mouse cursor also disappears and upon a sddm restart and login I typically get no mouse cursor either.

I tried removing the .cache as well as removed all non-default widgets but nothing seemed to help.

Since this is my work machine I am quite pressed to find a workaround (and would much prefer to not have to switch to other DEs), but I’m also worried that one of my 3 other machines that also run Kubuntu 22.04 may catch this bug.

Suggestions of how to debug/work around this issue would be appreciated!


are you sure everything is up to date?

sudo apt update

sudo apt upgrade

you can try changing your Desktop Setting to “Start with an empty session”

also go the About page in settings and paste the info here.

Thanks for your feedback!

Yes, I am sure everything is fully up-to-date.

you might consider adding backports to get a newer version of plasma

i’m using 5.27 and it seems more stable than the initial version that came with 22.04.

#a new repository can be added to apt via discover under
Settings > Software Sources > Other Software > Add
#the form of the syntax is
deb jammy main
deb jammy main

Thanks, is there a safe way to go back from backports to the original plasma if that does not work out (e.g. will my config files be backwards compatible)? Otherwise, I should probably make a full snapshot of my root and home partitions so I can revert if things don’t work out.

Side-note: it seems that my cursor disappears when i move all the way to the right edge of the screen.

Try to update to latest Plasma 5.27.10, I’m daily using KDE Plasma on my laptop and it’s pretty stable and fast.

Except for 2 annoying crashes that can randomly happen once or twice a day (promised to be fixed in Plasma6): QtWaylandClient::QWaylandGLContext::swapBuffers() and QQuickTransition::prepare(), plus that persistent Spectacle crash.

1 Like

there shouldn’t be any need to undo the upgrades, but it never hurts to have a snapshot to roll back to

I’m having the same issue, where Kwin and/or “Desktop effects” crash when I wake my laptop from sleep.

It pretty much happens every time i open the lid.

Sometimes it only closes a program or 2. Sometimes my entire GUI crashes and I have to force a reboot (windows will literally be flipping upside down, all desktop elements like icons, my task manager, background image will just… go black)

I made my own post yesterday about it because the issue is so severe. I’ve updated the version of Kubuntu I’m on so I’m on 23.10 myself, but this was happening before I updated my system and is still happening after as well.

1 Like

Try using 6.1 LTS kernel.

I have figured it out. I upgraded a recent nvidia driver (545.29.06) and since I was having trouble setting the fans speed on the second GPU with the default xorg conf (so no /etc/X11/xorg.conf file present), I generated one with nvidia-xconfig --cool-bits=4 and this generated a config file which contained both of my GPUs, two monitors (which I do have) and two Screen sections one for each Device/Monitor pair.

Apparently something in this setup trips kwin and makes it crash.

Note that my two actual screens are connected to the first GPU, so that could be an issue with this config file. Admittedly I’ve not been using my second screen recently so I am not sure if that worked at all with this xorg.conf.

In the meantime I downgraded to the 535 driver while chasing this bug. I just rern the nvidia-xconfig tool and generated new xorg.conf and it became obvious that this version does not include both devices in the config and kwin is also happy with that and no longer crashes.

So the most likely culprit is a weird xorg.conf, but I’ve not debugged further, I was happy that I don’t have to avoid the right edge of the screen like fire anymore :slight_smile:

Unfortunately the errors in the logs are too generic so the solution was not obvious and it was a guessing game.

Does anyone know how should an xorg.conf look like in my case? In the past I have used the above setup on headless servers where I started a “dummy” x11 in the background just to be able to manually set the fan speed on the GPUs.

how would i go about downgrading to that?

my system is on 6.5.0-14-generic (64-bit)

I’ve never had to downgrade the kernel before

if you run

apt list --installed linux-hwe* linux-image* linux-mod* linux-head* linux-gen*

you should get a list of all the kernel and kernel related files on your machine.

then you can drop the installed switch and tack 6.1 onto the image search

apt list linux-image-6.1*

but this does not turn up any “generic” kernels so that’s where my knowledge ends.

in theory, if you installed one of those oem kernels (and it’s corresponding header file) , ran the update-initramfs tool to rebuild the image and restarted, you should see the new kernel option under the Advanced menu in grub.

I’m sad to hear that. I don’t get those bugs. I use to get akonadi ones. It was easy to just disable. You can’t do that with kwin obviously! I have the kwin crash instead. I have upgraded. But I am sad, I might have to get XFCE Fedora. I can’t handle having these crashes in my life. I sad about the possibility of moving away from KDE. I hope with the upgrade everything is fine for me now. I am sorry I can’t help you though. But it’s good to compare notes regardless.

Kwin crashes purely at random but I use a desktop. Hopefully the upgrade I have been given has helped that. I am concerned about using Fedora XFCE. I want to stay where I am and I feel sad.

Please give some information about your hardware/system.
E.g. which distribution, X11 or Wayland, which Plasma, Frameworks and Qt versions or if you use an Nvidia graphics card and the proprietary drivers (the latter is one of the most common sources for problems, often enough regardless of the desktop environment).

1 Like

Thanks for taking an interest. I am not against KDE, but based on me using Nvidia I might have to go with XFCE Fedora. I do not want this to happen… I don’t like Cinnamon/Linux Mint (it had its own problems though and that’s why I don’t use it) but it crashed hardly at all with my Nvidia.
I am on Wayland, should I go to X 11? How long can we use X 11 for with all the mayhem and pushing people onto Wayland?
Qt version: 5.15.9
KDE Plasma: 5.27.6
Distro: Oracle Linux Server 9.3
Processor: 4 × AMD Ryzen 3 3200G with Radeon Vega Graphics
Graphics Processor: NV106
KDE framework: 5.108.0

Among the first things I would try/check are

  • is my system up-to-date?
  • try X11 instead of Wayland (!) - Xfce or Cinnamon currently use X11 only anyway…
  • try another (new) user account to check if settings/cache files in my user directory are the culprit
  • check if it is the the correct driver version for my Nvidia GPU and try another one if possible (e.g. 525.x instead of 535.x) - and try to avoid Nvidia GPUs in general whenever possible.

It certainly would also be a good idea to check log files with e.g. something like sudo journalctl -b -1 after a reboot (press arrow keys to scroll, [q] to exit) or with sudo journalctl -f until the Kwin crash occurs (press [Ctrl] [c] to exit) in Konsole.

This is hard to say and certainly depends on the distribution one uses.
As a rough estimate for Linux in general I would guess about until 2032 - that is when the maintenance support for Red Hat Enterprise Linux 9.x will run out (they are/were also one of the main contributors for X11).
Personally I am still using X11 and probably will do so for a while, because for my purposes Wayland is still in “beta stage”…

1 Like

You’ve certainly given me some things to think about. I feel more confident in going back to using X11 again. (I was always a big fan of X11. From a user point of view, I strongly disagree with the change. If I had influence, I would reject forcing Wayland onto people. I am not totally against Wayland, just the force/pressure to change.)
But how do you update graphics driver in KDE? I never saw an option for it.

Perhaps this will also fix some of your Kwin crashes in Wayland:
Fixed a way that KWin could crash in the Plasma Wayland session (Xaver Hugl, Plasma 5.27.11 Link)

Without a backtrace for any of these repeated crashes, it’s all guesswork.